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Foreword
Thank you for using BOCHU FSWELD intelligent welding control system!

BOCHU CypWeld Intelligent Welding Control Software (hereinafter referred to as CypWeld)

is an operating software designed for the 6-axis industrial robot teach-free arc welding system

FSWELD Intelligent Welding Control System (hereinafter referred to as FSWELD System). It

mainly consists of several core modules, including digital twin interface, robot motion control,

arc welding technique processing, production management and statistics, intelligent

processing assistance, rapid simulation, visual image information viewing, local help and

remote assistance. These modules work together to assist users in completing production

tasks efficiently.

Before using the software, please be sure that CypWeld is only available for actual

processing when working with BOCHU intelligent welding CNC and the corresponding license.

CypWeld will be in DEMO mode as any of the following three situations are detected:

 The CNC is not the one provided by FSWeld system.

 The license is not within its valid period.

 The CNC does not meet the requirement of the current product.

Please note that this manual only serves as the instruction of the main program of

CypWeld. Please refer to other manuals contact technical support for FSWeld system

installation or other content which requires for higher permission.

This manual is based on CypWeld C113.26. We apologize for the fact that the software you

are using may differ in some respects from what is stated in this manual due to the continuous

updating of system features. We make every effort to ensure that the contents of the manual

are applicable, but reserve the right of final interpretation. Contents of this manual are subject

to change without prior notice

For any questions or suggestions during usage, please contact us through the information

provided.
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Convention Symbol Explanation

 Notice: Supplementary or explanatory information for the use of this product.

 Caution: If not operated as specified, it may result in minor physical injury or equipment

damage.

 Warning: If not operated as specified, it may lead to death or serious physical injury.

 Danger: If not operated as specified, it will cause death or serious physical injury.

Safety Statement

The operation of the robot/external axis and the final welding result are directly related to

the welding material, welding machine, gases used, gas pressure, and the parameters you set.

Please set all parameters carefully and diligently according to your welding process

requirements.

Improper parameter settings or operations may result in suboptimal welding quality,

equipment damage, or even personal injury. FSWELD incorporates built-in safety features;

however, both equipment manufacturers and end users are required to strictly follow all

operating procedures to minimize safety risks

BOCHU shall not be held liable for any direct or indirect losses arising from the following

circumstances:

 Losses caused by misuse of this manual or the product;

 Losses due to non-compliance with safety guidelines;

 Losses resulting from force majeure events, such as natural disasters.

Additionally, welding systems in operation carry inherent risks. Users are responsible for

ensuring that they have comprehensive fault handling and safety protection mechanisms.

BOCHU assumes no responsibility for any incidental or consequential damages resulting

therefrom.



CypWeld User Manual

www.bochu.com

Revision History
Version No. Date Description

V2.1.0 2025/09/05 Updated based on CypWeld C113.26.
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Feature Overview

 Connects with mainstream 3D modeling software such as Tekla and SolidWorks, and

supports model files in .ifc/.step/*.stp formats.

 Adopts digital twin technology to realize the synchronous movement of the robot in the

software and the robot in the real workstation.

 Supports automatic calculation of welding pose and positioning pose, and displays them

visually in the software interface.

 Supports automatic planning of travel paths, with both collision detector and singularity

avoidance functions.

 Supports flat welding, horizontal fillet welding, vertical upward welding, vertical downward

welding, continuous wrap-angle welding and continuous curve welding.

 Supports oscillating welding in sine, pendulum, L-type and triangular patterns.

 Supports multi-layer and multi-pass groove welding/non-groove welding.

 Supports quick generation of intermittent welding.

 Supports workpiece initial positioning via vision, manual three-point, and mechanical

fixture methods.

 Supports multiple weld seam fine positioning methods including search-on-the-fly,

scanning positioning, butt-joint positioning and lap-joint positioning.

 Supports weld seam interruption and connection at the position of weld scallop.

 Supports automatic drawing output and batch generation of weld seams.

 Supports TCP (Tool Center Point), eye-hand calibration, and automatic toolpath remapping

after small-range changes in workpiece initial positioning.

 Supports automatic dirt detection on the seam tracker lens.

 Supports machine types such as fixed base, single ground rail, inverted cantilever and

gantry.

 Supports interpolated movement of positioners and robot.
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 Supports import and export of process parameter files, and automatic recommendation of

process parameters.

 Supports breakpoint positioning for resuming processing and setting the current position

as a breakpoint to resume processing after movement.

 Supports automatic torch cleaning and wire cutting.

 Supports parametric modeling of bracket, tower foot, H-beams and T-bars.
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Chapter 1 Product Overview

1.1 Adaptable Machine Types

BOCHU Intelligent Welding System provides three sets of products, each adapted to

different machine types. Before using the software, please make sure that the purchased

system hardware is compatible with the current machine. If the hardware is incompatible, the

CypWeld software will automatically enter the demonstration mode, in which only simulation

operations can be performed, and the equipment cannot be actually controlled.

Table 1-1 FSWELD System Classification

Intelligent Welding System Machine Model

2800L Single-machine workstation, 7-axis linear track, 7-axis cantilever (all

require 3D model import)

2800M All workstations (require 3D model import)

2800T All workstations (support 3D model import / 2D drawing import)

3800 All workstations (not require 3D model import)

1.2 Software Composition

The CypWeld software consists of the CypWeld main program and the CypConfig. During

installation, the system will automatically create a shortcut icon for the CypWeld main program

on the desktop; if the CypConfig is needed (requires advanced permissions), users must enter

the software installation folder and manually launch the CypConfig program.

Figure 1-2 CypWeld software icon and Machine Config shortcut icon
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Chapter 2 System Configuration & Procedures

2.1 Machine Tool Settings

During equipment installation, mechanical accuracy and rigidity must be ensured, with

specific requirements as follows:

 Robot accuracy: Error is within 1.5 mm when moving the tip of the welding torch end

around a fixed point.

 Seam Tracker accuracy adjustment: Error is within 1.5 mm for accuracy verification.

 Positioner accuracy: Error is within 2 mm for jog accuracy at zero-space points, and within

3 mm for model and actual workpiece deviation.

 The modeled neck diameter of the welding torch shall be 15 mm larger than the actual

size.

Machine tool settings must be configured in the CypConfig, with specific steps as follows:

Step 1 Network Scanning: Before conducting slave station scanning, ensure that all slave

stations are correctly wired, powered on successfully and in a non-alarm state.

Click Scan Slave. If the scanning is successful, the system will correctly display all

connected slaves.

Step 2 Layout Config: Select the base, robot, workbench and tool that match the

equipment in sequence, and enter the corresponding zero point and DH

parameters.

Step 3 Axis Config: Used to configure the motion parameters of the robotic arm and

external axes. The parameters in Axis Config are mainly related to hardware such

as drivers. For robot parameters, refer to the parameters on the robot teach

pendant. If there is no teach pendant, contact the robot or driver manufacturer to

obtain the relevant parameters.

Step 4 Welder: Select the currently supported welding machine model.
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Notice: This system currently only supports welding machines with the EtherCAT

communication protocol.

Step 5 Seam Tracker and Camera: If using the 3800 system, it is necessary to configure a

large line-scan camera.

Step 6 Alarm: Configure custom alarm display information triggered by corresponding

input ports.

Warning: The emergency stop button is only used for machine tool anti-collision

protection. Improper use may cause damage to the equipment; please operate with

caution.

Step 7 General Input/General Output/Resources: Configure custom input/output ports and

IO board signal resources.

Step 8 WKB: Set the button functions of WKB.

Step 9 Advanced Options:

1. Primarily used for setting the system language, which currently supports

Simplified Chinese and English.

2. Set the password for the expert mode entry. When accessing functions such as

the CypConfig, Procedure Table, Global Parameter, PLC Process, and Motion

Control Monitor. After checking Keep Expert Mode On, closing and reopening the

above pages will directly enter expert mode.

Figure 2-1 Expert mode and password settings

3. Data Permissions: When installing the software installation package, Please sign

the user information authorization certificate. Later, the authorization certificate

can also be reconfirmed and the authorization status modified here.
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Notice:

1. For details on the above machine tool parameter settings, please refer to FSWELD

Intelligent Welding Control System Installation Manual (General).

2. Currently, layout parameter configuration only supports to select existing options;

user-defined scene editing is not available temporarily.

2.2 Main Interface Overview

Figure 2-2 Main interface of CypWeld

The components of CypWeld main interface are shown in the following table:

Table 2-1 CypWeld Main Interface Components

No. Module Description

1 Toolbar  The toolbar lists commonly used software functions, including

import/export, parameter settings, technique library, calibration

tools, and servo status.

 Below the toolbar there might be a banner which displays current

alarm and warning information.

2 Weld Seam Settings Used to set and modify the weld seams to be welded. It also provides

functions for processing simulation, path planning, weld seam sorting,

and workstation switching.

https://drive.weixin.qq.com/s?k=AJEAqwcIAAcLXNth5d
https://drive.weixin.qq.com/s?k=AJEAqwcIAAcLXNth5d
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No. Module Description

3 Digital Twin The digital twin interface of CypWeld is modeled at the same scale as the

physical object. Movements in the physical space are fed back to this

interface in real time, allowing users to intuitively view collision planning,

idle movement, and welding pose of the physical object when operating

on the PC.

 Part 3.1 is the main hardware devices,which includes robot, external

axes, etc. It is necessary to contact BOCHU staff in advance for

software modeling.

 The 3.2 green area represents the automatically calculated optimal

working range of the robotic arm.

 The 3.3 yellow area is the imported workpiece model.

 The 3.4 square in the upper right corner provides view switching

options.

4 Seam Tracker Allows operation of the vision camera and adjustment of vision

parameters. The camera display interface enables real-time viewing of

the current image.

5 Log Records of current processing, user operations, and error/alarm

information

6 Control Used for jog control of the robot and external axes, providing switching

between four coordinate systems: World, Joint, Tool, and Base. It also

controls the processing status, allowing start, pause, resume, and stop of

processing, as well as controlling whether the welding machine ignites

the arc during processing.

7 Axis Monitoring Used to view the current coordinates, speed, and acceleration of each

axis (including robot joints and external axes).

2.3 Acquisition of Processing Models

CypWeld supports 6 methods for obtaining processing drawings: opening/importing local

3D drawings, 2D-to-3D conversion, custom modeling, parametric generation of box columns,

point cloud reconstruction, and cloud-based drawing import.
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2.3.1 Open/Import

Click the drop-down box of the File icon and select Open or Import, then select the target

3D processing model in the local file window. The differences between the two functions are

shown in the table below:

Table 2-2 Open VS. Import

Open Import

Supports *.step, .ifc, *.cwpt Supports *.step, *.ifc

Clears the current processing workbench Does not clear the current processing workbench

Supports selecting the latest 10 files Supports selecting the latest 10 files

Only supports loading a single model Supports box selection of multiple models in the

current folder of the pop-up window for one-time

loading

Using the File → Edit before Import function, you can pre-delete model plates before

importing/opening the local original 3D model to the current workstation.

Procedures: Left-click to select the target plate, then use the right-click menu to execute

the delete operation.

Figure 2-3 Edit before import
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2.3.2 2D-to-3D Conversion (Only Compatible with 2800T System)

Supports importing industry-standard 2D drawings of tower foot and converting them to

3D processing drawings using the 2D-to-3D function. For usage instructions, refer to 2800T

CypWeld Intelligent Welding Control Software User Manual.

Notice: This function is only available for the 2800T system. The converted 3D

drawings can only be used in 2800T system products; other systems do not support

opening such files!

2.3.3 Custom Modeling

Open via File → Custom Modeling. Currently, it supports parametric modeling of feature

parts such as bracket, single-bend bracket, tower base (without stiffeners), H-beam, box

columns, single V bevel, box-type column main weld seam single V bevel, and asymmetric

double V bevel.

2.3.4 Parametric Generation of Box Columns

Figure 2-4 Box column teaching modeling

https://drive.weixin.qq.com/s?k=AJEAqwcIAAcLXNth5d
https://drive.weixin.qq.com/s?k=AJEAqwcIAAcLXNth5d
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Step 1 Click Generate workpiece model in the toolbar to open the Teaching Modeling

page.

Step 2 Teach the three vertices of the standard square box column in sequence, then click

Record TCP Coordinates.

Step 3 Set the thickness and height parameters of the box column.

Step 4 Complete the 3D model generation.

2.3.5 Point Cloud Reconstruction (Only Compatible with 3800 System)

Figure 2-5 Point cloud reconstruction

Step 1 Before starting scanning, ensure that the robot pose will not collide with equipment,

workpieces, or the ground during the movement of external axes. After completing

the teaching of the initial pose of the robotic arm, click Record Coordinates to

record the scanning pose.

Step 2 Set the scanning method and scanning speed.
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Step 3 Start scanning the point cloud. The external axes will move according to the set

scanning direction, while the robot pose remains unchanged.

Step 4 Enter the point cloud reconstruction interface and perform the process of

reconstructing a 3D model from the point cloud.

Step 5 Save the reconstruction file and push the 3D model to the current bench.

Notice:

1. For detailed operation steps and precautions of point cloud reconstruction, refer to the

[3800] CypWeld Intelligent Welding Control Software User Manual.

2. Point Cloud Reconstruction is only available for the 3800 system. Before use, ensure

that the parameters of the large line-scan camera are configured in the CypConfig and

that the large line-scan camera is properly calibrated.

2.3.6 Cloud-Based Drawing Import

For specific operation steps, refer to the CypWeld-Tekla One-Click Drawing Splitting

Plug-in User Manual.

Notice:

1. Before use, ensure that the relevant BOCHU cloud service is purchased and the cloud

account registration is completed.

2. The production line number in the CypConfig must be consistent with that set in the

cloud service account.

3. The currently used equipment is connected to the Internet.

https://drive.weixin.qq.com/s?k=AJEAqwcIAAcLXNth5d
https://drive.weixin.qq.com/s?k=AJEAqwcIAAcLXNth5d
https://drive.weixin.qq.com/s?k=AJEAqwcIAAcLXNth5d
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2.4 Device Jogging

CypWeld supports jogging for both robots and external axes, with three jogging modes:

High, Low, and Step.

Figure 2-6 Jogging interface

2.4.1 Axis Jog

The robot can be jogged in the following ways: J1 to J6 joint jogging, world coordinate

system jogging, tool coordinate system jogging, and base coordinate system jogging.

2.4.2 External Axis Jog

Below the robot jogging buttons, G.X, G.Y, and G.Z represent external axis jogging. The

corresponding external axis jogging buttons are automatically displayed based on the current

usage scenario. Buttons for external axes not configured in the current scenario will be grayed

out.
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2.4.3 Common Axis Jogging (Positioner Jogging)

Click CommAxis Debugging to enter the interface. If no positioner is configured in the

current layout, this feature is unavailable.

Figure 2-7 Common axis debugging
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2.4.4 Jog Speed Settings

Click Jog Settings to enter the interface, which includes settings for the robotic arm (robot)

and extended axes (external axes + common axes). The robotic arm supports independent

settings for Jog High, Jog Low, and Jog Coordinates for each of its six joints. Additionally,

motion algorithms can be applied in the world coordinate system to achieve high-speed,

low-speed, and step-by-step control for linear and rotational movements. The same applies to

extended axes.

Figure 2-8 Jogging settings

Notice: The speeds set here only apply to manual jogging and do not include the rapid

movement speed used during processing and production.
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2.5 Machining Control

Figure 2-9 Machining control

The specific functions are described in the table below:

Table 2-3 Machining Control Functions

Buttons Description

Start Start processing. Before starting, the software automatically checks whether

the current drawing meets the processing conditions and whether there are any

breakpoints.

Pause Pause processing. During the pause, no changes can be made to the current

processing drawing.

Stop Stop the current processing.

Resume Corresponds to the pause function.

BreakPt LOC If the processing process stops or is interrupted unexpectedly, the software will

remember the breakpoint. As long as the workpiece model, weld information,

and path planning remain unchanged, the software will automatically locate the

point where processing last stopped.

Set BreakPt Manually set a breakpoint, using the current TCP position as the starting point

for the next processing.

Return Zero Click to return the robot or external axis to the zero point.

Feed/Retract Wire Adjust the length of the welding wire.

Return Gantry Axes When selected, using the Return Zero function will cause the external axis to

return to zero along with the robot.



CypWeld User Manual

www.bochu.com 16

Buttons Description

Dry Run When selected, processing will not activate the welder arc, only simulate the

processing actions.

Restart Overlap Set the distance the arc starting point will retract along the original welding path

when restarting after a pause, aiming to make the joint more better looking.

2.6 Information Storage

2.6.1 Processing Drawing Saving

Click File→ Save/Save As to save the processing drawing of the current station locally.

2.6.2 Parameter Backup

Click Tool → Auxiliary Tool → Parameter Backup to save the current scenario model,

configured machine parameters, and procedure parameters.

Figure 2-10 Backup parameters

2.6.3 Fault Information Saving

Click Help→ Save Fault Info to save fault information.

Figure 2-11 Fault information saving
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Custom time ranges can be set to filter the fault information to be saved. The three preset

time ranges from the old version (last two hours/last two days/last ten times) have been

integrated into the current interface and can be directly selected via the Time Range

drop-down menu.

Figure 2-12 Save fault information

By default, System Defaults is selected for fault information saving, which includes all

information except Rough Point Cloud and Precise Point Cloud. Rough Point Cloud and Precise

Point Cloud. can be selected by the user based on actual feedback scenarios.

Figure 2-13 Fault information saving interface
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Chapter 3 System Calibration

For detailed operational guidance on various calibration functions, it is recommended to

contact BOCHU technical support personnel to obtain accompanying instructional videos for

comprehensive training.

3.1 TCP/Zero Point Calibration

TCP/Zero Point Calibration Steps:

Step 1 Prepare a calibration tool with a tip (e.g., a tetrahedron calibrator). Place the

calibration tool with the tip facing upward and stabilize it within the robot’s

movement range.

Step 2 Click Tool → Parameter Settings → TCP/Zero Point Calibration to enter the

TCP/zero-point calibration interface.

Step 3 Record vertical coordinate positions. Use a 25 mm TCP calibration tip (if

unavailable, a welding wire can be used instead by adjusting the stick-out to 25

mm). Jog the arm so that the torch is in the vertical direction and the end of the

torch is aligned with the tip of the calibration pyramid, then record the coordinates.

Figure 3-1 Torch vertical and tip aligned with calibration point
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Figure 3-2 Record the vertical coordinates

Step 4 Record coordinates at different postures. Change the horizontal and pitch angles of

the torch, aligning the torch module to the tip of the calibration pyramid at four

different angles, and select and record coordinates as P1 to P4 for each pose.

Figure 3-3 Record coordinates at different poses

Step 5 If only calibrating 4 points, click Calibrate TCP Only → OK. If zero point calibration

is required, record at least 8 points and click Calibrate TCP and zero point→ OK.

Figure 3-4 Calculate calibration results.

Notice: Only click once to calculate the TCP result. Multiple clicks may affect the

accuracy.
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Step 6 Accuracy verification. Adjust the robotic arm so that the robot TCP points

vertically towards the tip of the calibration pyramid. Move the joints J4 to J6

incrementally in the world coordinate system to perform circular motions around a

point. Observe the maximum linear distance between the torch’s end and the tip of

the calibration pyramid during the circular motion. This distance represents the

maximum TCP error (typically 1 mm to 1.5 mm, depending on robot brand).

3.2 TCP Automatic Calibration

Before performing TCP automatic calibration, it is recommended to consult BOCHU

technical support to confirm whether the welder model supports the automatic calibration

function. To ensure calibration accuracy, replace the end of the welding torch with a BOCHU

standard calibration needle. Specific steps are as follows:

Step 1 Prepare a conductor plate (size at least 100 mm × 100 mm) and place it

horizontally. Turn on the welder and ensure the area around the robotic arm is clear,

with no unmodeled obstacles in the scene.

Step 2 Jog the robotic arm to about 10 mm above the center of the plate, ensuring the TCP

is as vertical as possible. Click Record Coordinates to record the starting

coordinates.

Figure 3-5 Record coordinates
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Step 3 Click Start calibration to begin automatic calibration.

Figure 3-6 Start calibration

Step 4 After the calibration is complete, save the calibration results and set the current

welding wire length to complete the calibration.

3.3 Eye-Hand Calibration

The steps of Eye-Hand Calibration are shown below:

Step 1 Prepare a calibration sample template (choose one of the following three

methods):

1. Lap joint (step piece): The mark point is a fixed point set by the user on the edge

of the upper step surface.

2. Tetrahedron: The mark point is the vertex of the tetrahedron.

3. Disk: The mark point is the marking point at the center of the disk.

Step 2 Adjust the robot’s pose so that the lower surface of the seam tracker is parallel to

the plate surface.

Notice:

1. During the subsequent eye-hand calibration process, any steps involving adjusting the

robot’s position must only be done in the world coordinate system, and the robot’s end

pose must not be changed. Only J1+, J1-, J2+, J2-, J3+, and J3- jogging in the world

coordinate system is allowed.

2. Ensure the robotic arm’s TCP accuracy is within 1.5 mm.
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Step 3 In CypWeld software, click Seam Tracker → Calibration to enter the hand-eye

calibration interface. Click Select to switch between Lap Joint, Tetrahedron, and

Disk.

Figure 3-7 Select corresponding template

Step 4 Collect tip coordinates. Control the robot’s movement in the world coordinate

system to align the TCP point or welding wire tip precisely with the mark point.

Click Get Tip Coordinate.

Step 5 Align the laser line with the mark point to collect data.

1. Jog the position of the robot: Fine-tune the robotic arm to enable the software

camera's field of view to clearly capture the features of the calibration part.

a. Lap Joint: The endpoint of the upper straight line of the top and bottom lines.

b. Tetrahedron: The vertex of the triangle.

c. Disk: The protruding straight line segment.

2. Verification and Recognition: Ensure that the red cross symbol in the software

remains stable and that the physical laser line accurately passes through the

feature point.
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3. Record Coordinates: Click Acquire Data to record the coordinates at this location.

Repeat step 5 to collect data from 6 different positions.

Figure 3-8 Laser line aligned with mark point (Using Tetrahedron as an example)

Notice: If the light is unclear and the mark point cannot be recognized in the window,

click Auto Exposure.

Step 6 Once all six data points have been collected, click Calculate Matrix to complete low

visibility eye-hand calibration. Results will be shown in the log panel.

The result must meet the following accuracy requirements:

 Low visibility deviation < 1 mm.

 High visibility deviation < 8 mm.

Figure 3-9 Calculate matrix (Using a tetrahedron as an example)
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Step 7 Click High Visibility, and repeat the above steps to complete high visibility

eye-hand calibration.

Notice: High visibility may not work well with thin lap joints or tetrahedron due to

limited recognition. A lap joint calibration surface with significantly different height may

be required.

Step 8 Seam tracker eye-hand calibration accuracy verification. Open Tool → Debugging

Tool → Seam Tracker Precision Debug. Move the robot until the mark point

overlaps with the laser. Click Record Recognized Coordinate → Start Motion, and

observe the deviation between the torch tip and the mark point at the end of the

movement.

Figure 3-10 Seam eye-hand accuracy test (using tetrahedron)

Caution:

1. Before accuracy verification, check the robot’s travel speed (recommended to be below

100 mm/s).

2. Hold the WKB before clicking Start Motion to prevent accidents such as collisions.



CypWeld User Manual

www.bochu.com 25

3.4 Auto Eye-Hand Calibration

The following is a brief description of the hand-eye automatic calibration steps. For

detailed instructions and precautions, refer to Section 4.2.3 of FSWELD Intelligent Welding

Control System Hardware Installation Manual.

Prepare a tetrahedron for calibration in advance. Before calibration, ensure the camera’s

bottom surface is roughly parallel to the ground.

Step 1 Open Tool → Parameter Settings → Auto Eye-Hand Calibration. Place the

calibration tetrahedron in the appropriate position as shown in the interface

diagram.

Figure 3-11 Auto eye-hand calibration

https://drive.weixin.qq.com/s?k=AJEAqwcIAAcOwqV20Y
https://drive.weixin.qq.com/s?k=AJEAqwcIAAcOwqV20Y
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Step 2 Point the robot TCP to the vertex of the tetrahedron and start automatic calibration.

Step 3 After calibration is complete, save and apply the calibration results.

3.5 One-Click Calibration for Calibration Workstation

The following is a brief description of the one-click calibration for the calibration

workbench. For detailed instructions and precautions, refer to Chapter 4, Software Function

Configuration, of ICS110P Automatic Calibration Workstation Installation Manual.

3.5.1 Calibration Workstation Configuration

Before performing one-click calibration, complete the calibration workstation

configuration. The configuration steps are as follows:

Step 1 Open Tool→ Parameter Settings→ Calibration workstation configuration. You can

configure the communication connection based the workbench models and serial

settings.

Figure 3-12 Configure the displacement sensor connection status

https://drive.weixin.qq.com/s?k=AJEAqwcIAAckBrFGWr
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Step 2 Ensure that the robot's circular point accuracy error is within 1.5 mm, then click

Calibrate Workstation. Follow the on-screen prompts to sequentially teach and

record the three marked points on the workstation using the TCP, completing the

workstation pose calibration.

Figure 3-13 Pose calibration

Step 3 According to the calibration pose, teach the robot to position the TCP above the

calibration object, click Record Marking Points, and verify the error. If the error is

greater than 5, it indicates that the pose calibration of the workstation is poor, and

the body accuracy needs to be checked before recalibrating. Otherwise, the

workstation configuration is complete.

Step 4 Similarly, verify the error of the vision calibration object.
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3.5.2 One-Click Auto-Calibration

Step 1 Replace the end of the welding gun with the BOCHU standard calibration needle.

Step 2 Open Tool → Parameter Settings → One-Click Auto Calibration interface, and

select the desired calibration item (calibrate all/only TCP calibration/only seam

tracker hand-eye).

Figure 3-14 One-click automatic calibration

Step 3 Click Start Calibration and wait for the calibration action to complete.

Step 4 After calibration is complete, review the results and perform calibration result

compensation.

3.6 Assembly Matrix Calibration

Assembly Matrix Calibration is used to calibrate the assembly matrix of external axes

(ground rails, cantilevers, gantries), and also allows calibration of the reduction ratio of

external axes. The following is a brief description of the assembly matrix calibration steps. For

detailed instructions and precautions, refer to Section 4.3 of the FSWELD Intelligent Welding

Control System Hardware Installation Manual.

Step 1 Open the interface via Tool → Parameter Settings → Assembly Matrix Calibration.

Before calibration, ensure that the robotic arm TCP calibration error is within 1.5

mm.

https://drive.weixin.qq.com/s?k=AJEAqwcIAAckBrFGWr
https://drive.weixin.qq.com/s?k=AJEAqwcIAAckBrFGWr
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Step 2 Place a marker at a fixed position, which can be a sharp cone or a tetrahedron. Use

the TCP to point to the marker and record the coordinates.

Step 3 Move the external axis by more than 100 mm, then point the TCP to the marker

again and record the coordinates. Repeat the collection of at least two points.

Step 4 Complete the calibration.

Step 5 Verify accuracy. Open Tool→ Debugging Tool→ Zero-space Jog interface to verify

accuracy. The maximum straight-line error of the external axis moving 1 m should

be around 2 mm.

Figure 3-15 Zero-space jog

3.7 Move Worktable

Right-click the worktable (blue square) or the positioner model, then click Move Worktable

to enter the move worktable interface.

The move worktable function is only used for the preliminary determination of the

worktable or positioner position and orientation and should not be used as the final step. The

worktable/positioner must be calibrated to determine the final pose.
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3.8 Worktable/Positioner Calibration

During calibration, note the following:

 The calibration methods for fixed worktables and single-axis/dual-axis positioners are

different and must be strictly distinguished.

 If there are multiple positioners, calibrate each one independently.

 Ensure TCP circular point accuracy ≤ 1.5 mm before calibration.

 In multi-station scenarios, only the current station's worktable or positioner can be

calibrated. To calibrate other worktables or positioners, switch stations.

3.8.1 Worktable Calibration

Worktable calibration steps are shown below.

Step 1 Right-click the worktable, click Calibrate Worktable to open the worktable manual

calibration interface, and confirm the worktable dimensions.

Step 2 Sequentially select three marked teaching points on the worktable surface, and

click Copy TCP Coordinates.

Figure 3-16 Mark point teaching

Step 3 Click Calibrate, then confirm and save in the upper right corner. In the digital twin

interface, the worktable will move to the calibrated position.
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3.8.2 Single-Axis/Dual-Axis Positioner Calibration

Step 1 Pre-calibration preparation:

1. Ensure the orientation of each axis of the positioner matches the real-world

direction.

2. Ensure the robot body accuracy is good, with TCP circular point accuracy ≤ 1.5

mm.

3. If the robot base has movable external axes, keep the them stationary during

calibration.

Step 2 Open Tool → Parameter Settings → Positioner Calibration. Fix the calibration cone

on the positioner, move the positioner so that the positioner coordinates in the main

interface axis monitoring match the recommended axis coordinates in the Record

Coordinates column.

Figure 3-17 Record coordinates

Step 3 Teach the robot TCP to the tip of the cone, click Record New Coordinates.

Step 4 Repeat the above operation to teach and record the coordinates for all

recommended values in the right table of the Record Coordinates column.
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Step 5 After coordinate collection is complete, click Calculate to view the calibration

results, then click Confirm to complete the calibration.

Figure 3-18 Calculate calibration results

Step 6 Accuracy verification. Open Tool → Debugging Tool → Zero-space Jog interface,

and jog the axis jog buttons on the interface. During positioner movement, observe

the follow-up movement of the robot end. The maximum error should be around 2

mm.

Notice: If both robot base external axes and positioners are present in the current

scenario, verify the calibration separately.
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3.9 Workbench Surface Calibration

Step 1 Ensure the robot’s circular point accuracy is within 1.5 mm before calibration.

Step 2 Use the robot TCP to poke three points on the worktable upper surface and record

them. The three points must not be collinear.

Step 3 After recording the three points, click Calculate upper surface. After calculation,

click OK to save the result.

Figure 3-19 Workbench upper surface calibration
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3.10 Fence Calibration

By calibrating the two fence surfaces of the fence, workpiece docking can be facilitated,

ensuring accurate workpiece positioning. The calibration steps are as follows:

Step 1 Right-click the workbench or positioner, click Add Fence (New Datum) to open the

calibration interface.

Step 2 Select three positions on Fence Surface 1 with significant differences in Z-direction

height, move the TCP to each point, and record the coordinates.

Figure 3-20 Fence surface calibration

Step 3 Repeat the above operation to complete the calibration of three positions on Fence

Surface 2.

Step 4 Click Calibrate to complete the fence calibration.
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Chapter 4 Workpiece Positioning

4.1 Manual Three-Point Initial Positioning

This is a universal workpiece positioning method suitable for all working conditions.

Specific steps are as follows:

Step 1 Pose adjustment:

1. Right-click the workpiece model, click Adjust Pose.

2. Manually adjust the workpiece model in the software to roughly match the

position and pose of the physical object. If the workpiece needs to be flipped,

reselect the bottom surface to adhere to the workbench.

Step 2 Workpiece manual positioning:

1. Right-click the workpiece model, and select Manual Calibrate Workpiece.

2. Use the mouse to select one point of the workpiece, jog the robot, and teach the

TCP to the same point as the workpiece, and record the coordinates.

Figure 4-1 Workpiece manual positioning
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Step 3 Repeat the above operation to record three sets of different coordinates. Click

Calibrate, and the software will automatically correct the model position to the same

position as the physical object.

Figure 4-2 Calibration result

Notice:

1. The three selected feature points will prompt a selection score. A low score (e.g., points

on the same horizontal plane, points too close) will prevent calibration.

2. The calibration result will also be given as a score. A low score will cause calibration

failure, and the workpiece position will not move.

3. This positioning method depends on the match between the model and the physical

object, requiring good assembly accuracy of the workpiece.

4.2 Fence Positioning

This method requires prior fence calibration. For specific calibration methods, refer to

Section 3.10 Fence Calibration. The fence positioning steps are as follows:

Step 1 Right-click the workpiece model, click Dock Workpiece.

Step 2 Select the two surfaces to be docked, corresponding to the two surfaces of the

calibrated fence.

Step 3 Complete workpiece positioning.

4.3 Seam Tracker Automatic Initial Positioning

Automatic initial positioning uses a vision camera to scan point clouds and register them

with the model, eliminating the need for manual precise point alignment. To ensure registration

accuracy, the following conditions must be met:

 Point cloud requirements: Sufficient point cloud data must be collected as a basis for
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registration.

 Equipment configuration: Currently, only scanning with base external axes is supported.

Standalone or positioner workstations are not supported.

 Workpiece size: The workpiece length should be ≥ 1 m to ensure sufficient point cloud

information is scanned.

The steps for seam tracker automatic initial positioning are as follows:

Step 1 Pose adjustment. Use pose adjustment to move the workpiece model to a position

where the initial deviation from the physical object is ≤ 1 m. If the deviation is too

large, the system cannot automatically adapt the scanning length, resulting in

insufficient point cloud data and affecting registration accuracy.

Step 2 Mode selection. Click Seam Tracker Initial Positioning to enter the seam tracker

initial positioning interface, and select single-workpiece or multi-workpiece mode.

1. Single workpiece: Manually move the robotic arm to position the TCP at one end

of the workpiece bounding box, and set the scanning direction according to the

world coordinate system.
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2. Multi-workpiece: The default scanning range is the entire workbench.

Figure 4-3 Seam tracker initial positioning

Step 3 Set the scanning speed, default 400 mm/s to 500 mm/s. Select the template based

on the physical workpiece type.

Step 4 Check Scan and Match as needed.

Step 5 Click Start to begin initial positioning. The initial positioning result and calculated

error will be displayed on the interface.
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Step 6 If the workpiece is symmetrical, initial positioning may produce ambiguous

solutions, and the system will automatically enter the registration solution

selection interface. You should manually select the correct solution based on the

matching situation in the digital twin interface:

1. Point cloud color indicators:

a. White represents the physical workpiece point cloud.

b. Red represents parts where the physical workpiece has more than the model.

c. Blue represents parts where the model has more than the physical workpiece.

2. The interface displays key deviation values between the model and the physical

object for reference.

3. Check Measure to manually measure distances for verification.

Figure 4-4 Automatic initial positioning ambiguity
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4.4 Line Scan Camera Initial Positioning

Based on the seam tracker initial positioning method, the large line-scan camera has a

wider field of view and can complete registration with fewer scans, improving positioning

efficiency.

Figure 4-5 Open line-scan initial positioning

Figure 4-6 Large line-scan initial positioning

Step 1 Open via Seam Tracker Initial Positioning → Line Scan Initial Positioning in the

function bar.

Step 2 Before starting initial positioning, jog the robot to the initial pose to ensure the

line-scan camera’s field of view is not obstructed, and there is no collision risk

during external axis movement. Click Record Scanning posture.
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Step 3 Set the scanning speed and workpiece template. Default scanning speed is 500

mm/s.

Step 4 Check Scan and Match as needed.

Step 5 Click Start for initial positions. The entire workbench will be scanned by default.

After successful initial positioning, Scan successful will appear, and the model will

automatically move to the same position as the physical object. Ambiguity

resolution is the same as for seam tracker initial positioning. This concludes the

large line-scan initial positioning process.

Figure 4-7 Successful initial positioning
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Chapter 5 Preparation Before Welding

5.1 Procedure Parameter Settings

In Procedure Parameter (also known as procedure library), you can set the procedure

parameters corresponding to each layer. Import and export of parameter packages is also

supported. For multi-layer multi-pass welding, parameters of each filter pass can be set

individually. For certain weld types (e.g., box-column main welds), the software provides

recommended offset parameters for multi-layer multi-pass filter pass.

The Help button (top right) provides troubleshooting tutorials. Scan the QR code with

WeChat to access the My Machine mini program for troubleshooting Q&A documents.

Figure 5-1 Procedure parameter interface
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5.1.1 Seam Params

Set the groove type according to the diagram. If no groove is required, default all

parameters to 0.

For multi-layer multi-pass welding, the welding position of each filter pass can be set.

However, if the set position does not match the actual workpiece placement, it will not take

effect. Filter pass positions different from the root pass are only valid in positioner layouts.

Offset and starting point of each pass can be configured. The reference frame for Y/Z-axis

offsets is consistent with the diagram.

Figure 5-2 Seam params
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5.1.2 Procedure Params

Set the welding machine parameters, including current, voltage, oscillation params, etc.

For details, refer to the Welding Process Debugging Manual.

Figure 5-3 Procedure params

https://drive.weixin.qq.com/s?k=AJEAqwcIAAc4uNEOxN
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5.1.3 Backfill Params

If welding speed is too fast, undercut or crater defects may form at the start/end points of

the weld. To address this, the software provides backfill parameters. By backtracking a defined

distance along the weld seam, sufficient molten pool fill is ensured. After crater filling, the

system automatically switches back to the ArcEnd Params of the Procedure Params and keep

on welding.

This feature only applies in drawing execution mode, not in teaching mode.

Figure 5-4 Backfill params

Figure 5-5 Backfill motion path
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5.1.4 Arc ReStart

Arc start may fail due to rust, gaps, or inaccurate seam recognition. Two recovery methods

are available:

 Scratch Start: Arc start at the position without coating within scratch distance. The torch

moves forward a defined scratch distance, strikes arc, then reverses back to the start point.

Weaving can be enabled during scratch start.

Figure 5-6 Scratch start motion path

 Arc Restart: Retracts and extends the wire in place to remove oxide film before reigniting.

 ReStart WireBackward: When the arc fails, the wire will be retracted for a period of time

to prepare for the next arc. Retracting too long will lead to the wire melt ball plugging

the conductive nozzle.

 ReStart Time: Reconnect time after retraction, generally consistent with the Arc

Reconnect Time of Procedure Params.

Figure 5-7 Reconnect motion path

Notice:

1. If both methods are enabled, the system attempts Arc Restart first; if it fails, Scratch

Start is triggered.

2. This feature only applies in drawing execution mode, not in teaching mode.
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Figure 5-8 Arc restart parameters



CypWeld User Manual

www.bochu.com 48

5.1.5 Corner Procedure

Defines parameters for continuous corner welding.

When transitioning from Weld 1 to Weld 2, the system applies Weld 1’s corner parameters.

You can configure Before-Corner Dist and After-Corner Dist to define the effective range.

Since torch posture changes significantly at corners, limiting maximum rotation speed

stabilizes movement (recommended 5 RPM to 20 RPM).

Figure 5-9 Corner procedure diagram

Figure 5-10 Corner procedure params
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5.1.6 Groove Adaption

For upward groove butt joint welds in box-column main seams with variable groove types,

visual scanning can be applied to measure the groove profile and enable adaptive welding.

Figure 5-11 Groove adaption params
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5.2 Procedure Table Setting

In the Procedure Parameter drop-down menu, click Procedure Table. When using the

automatic or manual weld generation, the software can automatically match the

corresponding procedure layer based on the weld position and plate thickness of the current

workpiece.

Figure 5-12 Procedure table

The primary filtering rules include weld position (flat welding, horizontal fillet welding,

vertical up welding, and vertical down welding), sheet thickness range, and sheet angle range.

For each matching rule, the corresponding procedure layer can be set, and the start and end

distances of welds under this layer can also be specified.

Enabling Continuous Welding opens a secondary interface where vertical up wrap welding

and vertical down wrap welding can be configured. The front and rear welds of a wrap welding

can have separate procedure parameters and optimal push-pull angles.

Notice: Because the start and end points of welds are often blocked by other sheets,

which may interfere with the robotic arm movement, the torch posture at these points

can be at its mechanical limit. By setting optimal push-pull angles, the software

automatically transitions the welding push-pull angle from the extreme posture at the

start and end points to the optimal angle during welding.
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5.3 Global Parameter Settings

5.3.1 Axis Motion Speed and Rigidity Settings

Caution: Make sure that the maximum speed and acceleration in the Platform

Configuration Tool are filled in strictly according to the robot manufacturer’s

recommended factory parameters. OEM should obtain these parameters from the robot

supplier. The corresponding parameter configuration files can also be downloaded from

the robot manufacturer’s official website.

Open the Global Parameter Settings interface, enable Expert mode, and in Robotic Arm,

you can select a preset rigidity level template to automatically populate the trajectory speed

and acceleration for each axis. It is recommended to use the default setting Rigidity level 2.

External axis motion speed/acceleration does not provide templates and must be configured

manually according to the manufacturer’s factory parameters.

Velocity Mode provides two options: Safe Mode and Rapid Mode:

 Safe Mode:

 The system automatically switches between high-speed and low-speed travel.

 When the robot arm is close to the workpiece, worktable, or other objects, it switches

to Linear low speed. Linear high speed is used for long-distance travel.

 Rapid Mode: Only Linear high speed is applied.

The input boxes and sliders below allow you to configure low-speed and high-speed

separately.

Figure 5-13 Velocity mode
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5.3.2 System Parameter Setting

Some parameters require enabling Expert mode before they can be set.

Figure 5-14 System parameter setting

Descriptions of system parameter settings are as follows:

Table 5-1 System Parameters Decriptions

Parameter Description

Prompt to clear the current

workstation when opening the

file

By default, when importing drawings via Open, all drawings already

imported to the current station will be cleared automatically. If this

option is selected, the system will display a prompt before clearing. See

Fig. 5-15.

Time estimation before

processing

After clicking Start, the estimated machining time will be displayed in

the log. A deviation of up to 20% may occur. See Fig. 5-16.

Generate new drawings using

digital twinning during

processing (reboot required)

Allows creating a new digital twin preset weld seam while processing is

in progress.

Robot Torque Collision

Detection/J5 torque error

threshold/J6 torque error

threshold

When enabled, the system activates torque collision detection to

protect cables by monitoring J5 and J6 torques. The torque error

thresholds define the monitoring limits, in N·m. Recommended value:

1000.

Accurate Time Estimation Provides a more precise estimation algorithm but requires longer

computation time and higher resource usage from the CNC host.
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Parameter Description

Robot feedback detection

(reboot required)/Collision

detection sensitivity

 When enabled, the system determines collisions by comparing the

calculated torque and feedback torque against the collision

detection threshold.

 Sensitivity threshold range: 0.1 to 1.

 0.1: Sensitive (default recommended).

 1: Less sensitive.

Figure 5-15 Open file popup prompt

Figure 5-16 Estimated processing time
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Chapter 6 Weld Editing

6.1 Manual Editing of Single Weld / Continuous Weld / Continuous Curve

6.1.1 Single Weld

Right-click the workpiece model → click Select welding edges to select the weld edge to

be edited. When the mouse pointer approaches a weld, it will automatically snap to the edge. If

two welds are close to each other, a pop-up dialog will appear, asking to choose the target

weld.

Figure 6-1 Adjacent weld selection
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Once a weld is selected, the system automatically enters the Edit Weld interface. The weld

is displayed on the model with the red endpoint marking the start point. Click Reverse to swap

the start and end point.

Figure 6-2 Edit weld

The welding system currently supports the following parameters:

 Weld Position: Flat welding, horizontal fillet welding, vertical up welding, and vertical down

welding.

 Weld Length: Fillet joint, lap joint, and butt joint.

 Weld Procedures: Curved weld, continuous welding, intermittent welding, etc.

The system automatically determines the applicable welding position and weld type based

on the model and seam location. For detailed definitions of joint boundaries, refer to the latest

version of the Technical Boundary Specification.

https://drive.weixin.qq.com/s?k=AJEAqwcIAAcXcwUMzj
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6.1.2 Continuous Welding

If the current weld endpoint connects with another weld edge, you can select that seam

again to enable continuous weld. As long as the welds are connected end-to-end, the

continuous weld procedure can be applied repeatedly without any limit on the number of

seams.

Figure 6-3 Continuous weld editing

Caution:Once continuous weld is enabled, the system will automatically apply corner

procedure. In this case, the reverse trajectory function is disabled, and the weld start

point cannot be reset.
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6.1.3 Auto Connect Continuous Curve Weld

For smooth continuous curves, use Auto connect continuous curve weld to set up the

curved weld.

Figure 6-4 Continuous curve weld illustration

Caution:

1. If the curve is closed, the weld start point will be automatically adjusted based on the

robot arm’s travel range.

2. Continuous curve and continuous weld cannot be used simultaneously.

3. The default search mode for continuous curve welds is Scan.
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6.1.4 Manual Connect Continuous Curve Weld

If external issues with the model cause gaps in a continuous curve, use Manual connect

continuous curve weld to repair it. The gap must be less than 50 mm. The missing segment

will not rely on model data; instead, the welding path will be automatically generated after

scanning and tracking. By default, multiple segments of a continuous curve weld use the same

procedure layer.

Figure 6-5 Manual connect continuous curve weld

6.1.5 Welding Parameter Settings

Figure 6-6 Parameter settings
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Detailed parameter descriptions are as follows:

Table 6-1 Welding Parameters, Search Parameters, and Positioner Parameters

Parameter Description

Weld Position Includes flat welding, horizontal fillet welding, vertical up welding, and

vertical down. Automatically determined by the system. For positioner

layouts, manual adjustment is required.

Wire Length Refers to the stick-out length, i.e., the distance from the contact tip at the

wire exit to the molten pool. Accuracy depends on TCP calibration and the

standard stick-out value input.

Weld Distance Equivalent to weld length; defaults to the model edge length. Start/end

distances can be adjusted manually.

Travel Angle The angle between the welding wire and the weld normal vector. A travel

angle of 0° means the wire is perpendicular to the weld.

Depart/Approach Angle Travel angles at the weld start/end points. The intermediate travel angle

gradually transitions to the optimal value set.

Intermittent Welding Supports custom single-pass length and weld interval. The system

automatically adapts the intermittent welding weld to the total weld length.

For curves or continuous welds, the software automatically calculates and

connects full welds across corners.

Wrap Parameters Supports setting wrap parameters. Even if the model does not contain

explicit corner edges, the system can execute wrap welding. Wrap welding

follows straight-line procedure and do not use arc tracking.

Search Parameter By default, fillet welds use Fly for search, some weld types allow manual

adjustment of positioning methods. Specific seam searching types and

boundary rules are detailed in the latest [Technical Boundary Specification].Positioner Parameter In positioner layouts, manual input of rotation angles for each axis is

supported to constrain weld position. If not selected, the software calculates

automatically.
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6.1.6 Update Seam Parameters

Supports updating welding and positioning postures either independently or

simultaneously. When the weld location or robot travel is restricted, synchronous updating may

take longer.

After updating weld parameters, the digital twin interface automatically refreshes the

welding torch posture and positioning laser scan range (green line). Only when both update

buttons in the weld editing interface turn green can you confirm and save the operation via the

confirm button in the upper-right corner.

Figure 6-7 Updated seam parameters
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6.2 Multi-layer Multi-pass Welding Manual Editing

Right-click the workpiece and select Add Multi-layer Multi-pass Weld to enter the editing

interface.

6.2.1 Import from the Procedure Table

Supports automatic parameter configuration for multi-layer multi-pass welds. All you

need is to preset multi-layer multi-pass welding procedures in the procedure table. After

selecting the corresponding procedure layer and updating parameter matching, the system will

automatically write in information such as groove geometry, weld pass quantity, filter pass

offset, and procedure parameters of each pass.

Figure 6-8 Example of importing multi-layer multi-pass welding parameters from the procedure table

6.2.2 Multi-layer Multi-pass Welding Parameter Manual Setting

The operation steps are as follows:

Step 1 Set groove type. Select the groove type based on the actual geometry. Currently

supported types include: natural bevel, box-type column main weld seam single V

bevel, I-shaped groove, asymmetric double V bevel, V groove, etc.

Step 2 Switch main board. The main board surface is used to determine the offset

direction when setting filter pass offsets. The software will automatically select the

two adjacent sides near the welding position as the main board surfaces.
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Step 3 Set groove geometry parameters. Illustrated diagrams are provided to explain the

meaning of each parameter.

Figure 6-9 Set groove geometry parameters

Step 4 Edit pass count.

Step 5 Edit Root Pass. Enter the root pass editing interface to configure welding position,

push/pull angle, and searching parameters. The parameter settings are consistent

with those in the single weld editing interface. Additional parameters such as root

pass offset can also be set in the main interface of multi-layer multi-pass settings.

Step 6 Edit filter pass. Select the target filter pass from the weld list, set offset parameters,

and the system will automatically perform offset calculation.

Notice: During weld procedure debugging, completed multi-layer multi-pass welding

procedures can be imported into the procedure table.



CypWeld User Manual

www.bochu.com 63

6.3 Select Surface and Add Weld

When adjacent welds are hard to distinguish, or when positioning errors occur due to

model deviation, you can directly select the intersection of two adjacent faces to determine the

weld position.

Right-click the workpiece, choose Select Surface and Add Weld, then select two adjacent

angled surfaces. The software will automatically calculate their intersection line as the weld.

The two surfaces do not need to be physically connected; the software will perform projection

automatically.

Figure 6-10 Select surface and add weld
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6.4 Auto Generate Toolpath

Auto Generate Toolpath refers to intelligent planning of all welds within the robot’s travel

range.

Right-click the workpiece, select Auto Generate Toolpath, and enter the Auto Generate

Drawing interface. Select H-beam, Feul tank or Fillet Weld template based on the weld type.

When selecting the Fillet Weld template, you need to specify the minimum weld length and, if

required, check Auto connect continuous welds.

Figure 6-11 Auto generate drawing interface

Figure 6-12 Wait for the software to automatically generate welds
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6.5 Select Rib and Create Weld

By manually selecting a rib, the software intelligently plans all welds that can be welded.

Step 1 Right-click the workpiece, choose Select Rib and Create Weld, and enter the

operation interface.

Figure 6-13 Manual select rib and add weld interface

Step 2 When moving the mouse pointer over the workpiece, the part boundary will be

highlighted in blue. Click on the rib to record the selection. Multiple ribs can be

selected by consecutive clicking.

Figure 6-14 Select ribs
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Step 3 After selection, click the confirm button at the top-right corner, and the system will

automatically generate welds.

Figure 6-15 Select rib and auto generate toolpath
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Chapter 7 Processing Planning

7.1 Weld Sequence

After welds are generated, weld sequencing must be performed. By optimizing welding

order and planning torch travel paths, both welding efficiency and quality can be improved.

Three sequencing methods are available.

7.1.1 Manual Sequence

Select the weld to be adjusted, then click the Weld Up/Weld Down buttons to manually

rearrange the weld order.

Figure 7-1 Manual sequence

7.1.2 Auto Sequence

With automatic sequencing, the software calculates the optimal weld order based on the

model and weld data.

Figure 7-2 Auto sequence icon



CypWeld User Manual

www.bochu.com 68

Step 1 Click Auto Sequence to open the interface and select the appropriate method

according to the workstation type:

 Shortest path of joint travel: Based on minimizing joint rotation angles.

 Position sort Movepath: Based on minimizing positioner rotation.

 Along ground rail direction: Sorts along the positive ground rail direction, with

optional reverse direction.

Figure 7-3 Sequencing method

Step 2 When Along ground rail direction is selected, you can check against ground rail

direction or interleaved sequencing of multi-layer multi-pass welds.

 Against ground rail direction: Used in multi-robot welding on the same rail. To

avoid collisions caused by opposing weld directions, sequencing is adjusted so

that all robots weld in the same direction.

 Interleaved sequencing of multi-layer multi-pass welds: To prevent heat distortion

from welding multi-layer multi-pass on one side only, alternating sequencing is

applied. Root passes are alternately welded on both sides, followed by sequential

filter passes welding by layer on one side.

Figure 7-4 Interleaved sequencing of multi-layer multi-pass welds

Notice: Conditions for interleaved sequencing of multi-layer multi-pass welds: Plate

thickness < 30 mm; supports horizontal fillet welding and but joint flat welding; not

applicable to vertical welds; closed geometries (e.g., rings, hatch covers) with inner and

external layers may be affected.

Step 3 Click confirm (top right) to apply sequencing.
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7.1.3 Sort on the model

Figure 7-5 Sort on the model icon

Supports sequencing by clicking welds directly in the digital twin model.

Step 1 Two sequencing modes are available:

 From Start: Click to sequence all welds.

 Start from current weld: Sequence only the remaining unsequenced welds.

Step 2 Welds are shown in gray after the mode is selected. By clicking welds in sequence,

they are highlighted with layer colors and numbered for clear visualization.

Figure 7-6 Select weld to sort on the model

Step 3 Click confirm (top right) to apply.
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7.2 Edit Weld

Figure 7-7 Edit weld icon

Select a weld and click the icon to enter weld editing mode. For parameter details, see

6.1.5 Welding Parameter Settings.

7.3 Filter and Modify

Filter welds by length.

Step 1 Set filter conditions:

1. Manually select weld positions.

2. Measure weld length in the layout and input the length range.

Figure 7-8 Set filter conditions

Step 2 Click Filter: The software automatically filters welds.
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Step 3 Select the filtered welds and perform batch modification in Welding Parameter.

Figure 7-9 Batch modify

Step 4 Click confirm (top right) to apply changes.

7.4 Remapping

If layout parameters change (e.g., TCP recalibration, seam tracker recalibration) or

workpiece position changes (e.g., re-fixturing, pose adjustment), click Remapping to

automatically adapt existing toolpaths.

Figure 7-10 Remapping
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7.5 Path Planning

After welding posture, search posture, and procedure parameters are set, use Path

Planning to automatically optimize robot travel between welds and between welding and

searching motions.

Path planning steps:

Step 1 Start Planning: Click Path Planning in the weld list. The system calculates the

optimal travel path.

Figure 7-11 Path planning icon

Step 2 Progress Monitoring: A progress window in the digital twin displays real-time

status.

Figure 7-12 Progress monitoring

Step 3 Completion: When progress reaches 100%, the log displays Path Planning OK.

Step 4 Ready state: The complete path data is generated.
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7.6 Simulation

After path planning, Simulation visualizes the full robot (and positioner) motion in the

digital twin, including: TCP travel paths, welding paths, and searching paths. This allows users

to verify machining feasibility before execution.

The execution steps are as follows:

Step 1 Complete path planning.

Step 2 Click Simulation (top right) in the weld list.

Figure 7-13 Simulation icon

Step 3 Observe robot motion in the digital twin.

 Simulation Speed: Enter 1 to 50 to control playback speed.

 Step Speed: Enter 1 to 50 to control incremental step distance.

Figure 7-14 Simulation interface
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7.7 Bench and Group Switching

When multiple benches or weld groups exist, they can be switched in the designated area

of the interface.

Figure 7-15 Bench and group switching
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Chapter 8 Digital Twin Interface

8.1 Initial Positioning Point Cloud

The initial positioning point cloud is used to evaluate the alignment between the scanned

point cloud data and the workpiece model, serving as a reference baseline for machining.

Figure 8-1 Initial positioning point cloud

8.2 Best/Max Workspace

Figure 8-2 Best/Max workspace

 Best workspace: The green rectangular area in the illustration represents the robot’s

optimal working range.

Figure 8-3 Best workspace diagram
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 Max workspace: The red spherical area in the illustration represents the robot’s maximum

working range.

Figure 8-4 Max workspace diagram

8.3 View Switching

You can directly select a view from the list to switch to the corresponding perspective. The

default view of the software can also be set here.

Figure 8-5 View switching
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8.4 Obstacle Manager

Since various types of obstacles (such as anti-collision devices) may exist in the actual

working environment but are not automatically displayed in the digital twin interface, you need

to manually add these obstacle models. This ensures that path planning can effectively avoid

potential collisions.

Figure 8-6 Obstacle manager
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Chapter 9 Highlight Features

9.1 Co-Rail Multi-Robot Communication

Figure 9-1 Co-rail multi-robot setting
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The co-rail communication function supports linear track and 7-axis gantry systems. The

setup procedure is as follows:

Step 1 Connect multiple CNC hosts in series with network cables. Go to Platform Config

Tool → Layout Config → Base Config, check Co-Rail Multi-Robot and fill in the

Corail Robot Quantity, then save and exit.

Figure 9-2 Co-rail multi-robot config

Step 2 Designate the leftmost robot as Machine 1 (Master). On Machine 1, open CypWeld

and go to Connection Status → Settings to open the Connection Parameter

Settings interface.

Step 3 Configure the following:

 Safety Distance: Set according to on-site conditions.

 Co-Rail Axis: Default GX axis for 7-axis systems, and GY for 8/9-axis systems.

 Current Master Index: Set according to on-site conditions.

 Master Co-Rail Axis + Direction: Set according to on-site conditions.

Step 4 Configure the Machine1 (Master) IP address.

Notice: Find the IP via Win + R → enter cmd and press Enter → enter ipconfig and

press Enter→ IPv4 Address.

Step 5 Configure the IP addresses of the remaining robots according to the total robot

number. Set the rail axis positive direction and the zero-point distance between

robots.

 Zero-point distance: The actual spacing between robot bases when aligned at

GX/GY zero position.

Step 6 Click OK to complete.
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Notice:

1. The Co-Rail Multi-Robot option must be enabled in each machine’s platform

configuration tool.

2. When configuring Machine 1 (Master), ensure CypWeld is open on all other machines.

9.2 CleanTorch & CutWire Setting

Follow the steps below to configure the torch cleaning and wire cutting station:

Step 1 According to the actual wiring position on HPL2720E, open CypConfig → General

Output, and configure the output port. After configuration, save and close the tool.

Step 2 Open CypWeld, click Tool → Parameter Settings → CleanTorch_CutWire Setting to

enter the CleanTorch & CutWire Setting interface.

Step 3 Activate Enable Auto CleanCut, and sequentially teach and record coordinates of

clean torch safe point, clean torch position, cut silk position, and jet oil position.

Figure 9-3 CleanTorch & CutWire Setting interface
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Step 4 Navigate to PLC Process → Execute Custom PLC → Clean Torch Cut WeldingWire

to enter the PLC interface. Use the default process, then click Import from Preset

Process→ Save. (PLC Process password: 61259023)

Figure 9-4 Clean torch PLC

Figure 9-5 Cut WeldingWire PLC



CypWeld User Manual

www.bochu.com 82

Step 5 Use the CleanCut Cycle setting to enable automatic operation, or manually trigger

the process via PLC.

Figure 9-6 CleanCut Cycle setting

9.3 Mark Settings & Set Docking

Mark setting steps:

Step 1 Go to Tool→ Parameter Settings→Mark Settings.

Figure 9-7 Mark settings
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Step 2 Move the robot to the target posture and click Set as Mark.

Step 3 Click OK to activate the mark point in PLC configuration.

Dock setting steps:

Step 1 Go to Tool→ Parameter Settings→ Set Docking.

Figure 9-8 Set docking

Step 2 Set docking points for each bench. Docking points can be any predefined mark

point.
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9.4 Groove Self-adaptive of Box Column

Groove self-adaptive of box column is set as follows:

Step 1 Go to Generate workpiece model to enter the corresponding interface.

Step 2 Teach three edge points of the workpiece and record coordinates. The system

performs parametric modeling and initial positioning automatically.

Figure 9-9 Teaching modeling
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Step 3 Input Cover Thickness and Side Plate Thick to adjust plate dimensions. Confirm in

the top right, and the box column will be parametric modeled in the digital twin

layout.

Figure 9-10 Adjust plate dimensions

Step 4 Right-click the model → Add Multi-Layer Multi-Pass Weld to set groove geometry

and welding parameters, or load presets from the procedure table.
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Step 5 For Boss Interruption: Right-click workpiece → Box column toolpath generation.

Configure during initial weld editing or after multi-layer multi-pass parameters are

set.

1. Auto scan boss: Select weld edges to truncate, set groove parameters, then click

Start scan.

Figure 9-11 Auto scan boss settings

2. Manual Boss Teaching:

a. Check Manually add boss face to open the manual teaching interface.

b. Jog the robot to the boss location, and record coordinates.

c. The boss appears as a white rectangle in the model (recommended slightly

higher than actual boss for safer path planning).

Figure 9-12 Boss setting succeed
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9.5 Seam Tracker Protective Lens Check

Contamination on the seam tracker protective window/lens may cause recognition errors

or scanning failure. Regular inspection is recommended. Lens checking steps:

Step 1 Go to Tool → Seam Tracker Protective Lens Check.

Step 2 Select the marker type.

Step 3 Jog the robotic arm so that the end of the torch reaches the marked point position,

with the bottom face of the seam tracker as parallel as possible to the horizontal

plane. Then click Record Coordinates.

1. Triangular (Pyramid) Marker: Tip of the prism.

2. Disc Marker: Center of the disc.

Step 4 Click Start to begin the automatic protective lens check.

Figure 9-13 Seam tracker protective lens check
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9.6 Machining Information

Step 1 In Global Parameters, enable Time estimation before processing.

Figure 9-14 Global parameter settings

Step 2 In the View menu, click Statistics to open the processing statistical information for

real-time monitoring.

Figure 9-15 Processing statistical information
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Chapter 10 Auxiliary Tools

10.1 Measure

Right-click and select Measure to measure the distance between two points, or directly

select a line to measure.

Figure 10-1 Measure

10.2 Select Point

Right-click and select Select Point to choose a specific point. A system dialog will display

the coordinates of the selected point and prompt whether to move to that point. Click OK to

move the robot tip to the selected location. This function is generally used during initial

positioning error measurement.

10.3 Arc Start Debugging

Arc start debugging is used to adjust welding parameters. The operation steps are as

follows:

Step 1 Confirm that the software is ready and the robotic arm TCP has moved to the

starting position for welding.
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Step 2 Select the welding movement direction as required.

Step 3 Enter weld path length, set teaching end, and define in-place welding direction.

Step 4 Set the welding procedure parameters and determine if the actual arc start is

required.

Step 5 Click Start to begin arc start debugging.

Figure 10-2 Arc start debugging
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10.4 Sectional Continuous Welding Debugging

For welds that cannot be automatically recognized by the software, a manual teaching

method can be used to set the welding path and perform welding operations. The operation

steps are as follows:

Step 1 Make sure the software is ready, and the robotic arm is in a safe position, ensuring

no interference during motion.

Step 2 Make sure you have recorded at least two teaching points.

Step 3 Set the welding procedure parameters and determine if the actual arc of the welder

is required.

Step 4 Click Start to begin the sectional continuous welding debugging.

Figure 10-3 Sectional continuous welding debugging
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10.5 System Delay Measurement

Step 1 Navigate to Tool → Parameter Settings → System Delay Measurement and ensure

all axes have returned to zero position.

Figure 10-4 System delay measurement

Step 2 Ensure there are no obstacles near the gantry. You can select the axis to be tested,

with all axes being the default option. Then, click Start Measurement.

Step 3 The Measurement Results box will display the calibrated delay for each axis. If

“Calculation Result Available” is shown, the measurement is successful.
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Step 4 Compensate. Go to Procedure Parameter → Global Procedure → Arc Tracking,

enter the system delay measured in Step 3 into Phase delay in sampling.

Figure 10-5 Phase delay sampling

Notice: System delay measurement may result in the following situations:

1. No result: Caused by inconsistent speed units between the drive and software. Change

the drive encoder type to match the speed units.

2. Result unusable: Axis delays are inconsistent. Adjust drive delays (consult the drive

manufacturer). Axial errors must be within 5 ms.

3. Usable result: Enter the final measured value into Phase delay in sampling. For Aotai

welders, add 40 ms to the final value before entering.
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10.6 Robot Identification

Robot identification currently supports upright mounting only. The operation steps are

described as follows:

Step 1 Open Platform Configuration Tool → Layout Config → Robot Configuration. Select

the correct robot model for Dynamic Model.

Figure 10-6 Dynamic model setting

Step 2 Move the robot to a clear space and rotate the J1 axis to ensure no obstacles in

front or behind the robot.
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Step 3 In the settings panel, click Global Parameter to open the Global Parameter Settings

interface, and enable Expert mode. Click Robot Arm, and set Trajectory motion

speed limit to 10 RPM for all axes. Restore previous values after identification.

Figure 10-7 Set trajectory motion speed limit
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Step 4 Navigate to Tool → Parameters Settings → Robot Identification, and click Record

Home Position and Start Auto-Selection.

Figure 10-8 Record home position and start auto-selection

Step 5 Click Preview trajectory to generate a yellow trajectory on the model.

Figure 10-9 Preview trajectory
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Step 6 Click Start Slow Motion. After completion, click Start Fast Motion.

Figure 10-10 Slow/Fast motion

Step 7 After fast motion, click Select Next and repeat steps 5 to 6 at least five times.

Step 8 Click Calculate Errors and then perform Apply dynamic parameters to complete

body identification.

Caution:

1. Due to high speed and large coverage of the identification trajectory, there is a potential

safety risk. Closely monitor the robot’s motion and be prepared to use the emergency

stop.

2. Units in the error analysis table are percentages; recommended parameters are

unitless.

3. If results are unsatisfactory, re-record the start position or try a different preset

trajectory.

4. External interference (collision, cable pull, etc.) may reduce identification accuracy. In

such cases, re-record the start position and perform a second identification.
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10.7 Friction Identification

The operation steps for robot friction identification are described as follows:

Step 1 Navigate to Tool → Parameters Settings → Friction Identification, and click Return

Zero.

Figure 10-11 Friction identification

Step 2 Click Start. During identification, all axes move sequentially. The process stops

automatically after completion.

Step 3 Click Calculate Errors. If satisfactory, perform Apply dynamic parameters to

complete friction identification. If not, reperform Return Zero and try different

Speed Ratio values.
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10.8 Nozzle/Collision Box Parametric Modeling

CypWeld supports parametric modeling of the welding nozzle. After modeling, the

software automatically generates model redundancy, facilitating physical collision calculations

and smoothness levels in welding procedure parameters.

The steps for the nozzle parametric modeling are described as follows:

Step 1 Go to Offline Programming Parameter→ Nozzle Parametric Modeling.

Figure 10-12 Nozzle parametric modeling entrance

Step 2 Fill in the nozzle model parameters on the left according to the diagram on the right

of the function page.

Figure 10-13 Nozzle parametric modeling interface

Step 3 Click Create to automatically include the nozzle model parameters in calculations.
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The steps for the collision box parametric modeling are described as follows:

Step 1 Go to Offline Programming Parameter→ Collision Box Parametric Modeling.

Step 2 Set the collision box dimensions in a stepwise manner. By default, each layer is a

cylinder defined by height and base diameter. Each layer is configured left to right,

corresponding to the dimension table from top to bottom.

Figure 10-14 Collision box parametric modeling

Step 3 At the bottom of the Collision Box Modeling page, Add is used to add a cylinder

layer; Delete is used to remove the selected layer and its dimension data. After

completing parameter setup, click OK to finalize collision box modeling.
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10.9 Monitoring Tool

10.9.1 Extension Board Monitoring

Used to monitor all I/O signals and provide test functionality for each axis. Navigate to

Tool→Monitoring Tools→ Extension Board Monitoring.

Figure 10-15 Extension board monitoring
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10.9.2 Real-time Curve Monitoring

Used to monitor parameter feedback during the welding process, such as arc tracking

cycles and real-time welding current. Navigate to Tool → Monitoring Tool → Real-time Curve

Monitoring.

Figure 10-16 Real-time curve monitoring
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10.9.3 Motion Control Monitoring

Used to monitor real-time motion status and servo information of the robot’s six axes and

external axes. This tool also allows setting the zero point of the external axis or the robot

body’s six axes. Navigate to Tool→Monitoring Tool→Motion Control Monitoring.

Figure 10-17 Motion control monitoring

10.9.4 Servo Alarm Information

Used to view detailed servo alarm information. Navigate to Tool → Monitoring Tool →

Servo Alarm Info.

Figure 10-18 Servo alarm information
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10.9.5 Welding Monitoring

Used to monitor welding track abnormalities and welding current status. Navigate to Tool

→Monitoring Tool→Welding Monitoring.

Figure 10-19 Welding monitoring



CypWeld User Manual

www.bochu.com 105

Chapter 11 Parameter Description

11.1 Offline Programming Parameter

11.1.1 Refer Search

Figure 11-1 Refer search

The parameters are described in the following table:

Table 11-1 Refer Search Parameter Description

Parameter Description

Apply to  All Welds: Applies globally to all welds.

 Welds with refer search set: Applies only to welds where Weld Editing →

Search Method is set to Refer Search.

Refer Method  Direct Reference: Multiple weld seams with the same start point require

scanning only once.

 Distance Reference: Other weld seams within the configured reference

distance can share the reference.

Refer Distance Defines the allowable distance range for reference. Other weld seams within

this distance can use the reference.
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11.1.2 Collision Detection

Figure 11-2 Collision detection

The parameters are described in the following table:

Table 11-2 Collision Detection Parameter Description

Parameter Description

Seam Tracker Bounding

Box Tolerance

Defines the bounding box size of the seam tracker, used for collision

detection of the seam tracker model.

Seam Tracker Antenna

Length

Sets the antenna length of the seam tracker. This simulates the tracker’s

signal cable for obstacle avoidance calculations during welding in narrow

areas. See Figure 11-3 for reference.

Fill the space between

torch and seam tracker

By default, the gap between the seam tracker and the torch does not allow

other models to pass through.

Welding Collision Offset Defines the offset threshold for collision planning during welding.

Search Collision Offset Defines the offset threshold for collision planning during searching.

Min Travel Collision Offset Defines the offset threshold for collision planning during travel.

Base collision offset When auxiliary equipment such as welders, wire feeders, or electrical

cabinets is mounted on the robot base and represented as a single unified

model in the digital twin environment, this parameter sets the offset

threshold for collision planning.
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Figure 11-3 Seam tracker antenna length

11.1.3 Seam Tracker Initial Positioning

Figure 11-4 Seam tracker initial positioning

The parameters are described in the following table:

Table 11-3 Seam Tracker Initial Positioning Parameter Description

Parameter Description

Z-Plane Collision

Detection Offset

During initial positioning, the scanning height of the seam tracker is

determined by the imported model. Since deviations may exist between the

digital model and the actual workpiece, this parameter defines the collision

detection offset .

Max feature point error for

initial positioning

In the three-point initial positioning function, this sets the error threshold

between the teaching points and the model points. If the deviation exceeds

this threshold, the calibration will be considered as failed.
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11.1.4 Algorithm Branching

Figure 11-5 Algorithm branching

The parameters are described in the following table:

Table 11-4 Algorithm Branching Parameter Description

Parameter Description

Weld seam pose planning

algorithm

Defines whether the rotation angle is automatically optimized during weld

seam editing. This improves planning success rate but may affect weld

formation quality.

Linear track linkage

optimization

When enabled, the external axis will automatically coordinate during

searching if the robot arm’s travel is insufficient.

Linear track linkage

optimization

When enabled, if the robot arm travel is insufficient during seam tracking,

the external axis will automatically be linked for coordinated motion.

Scan larger area and

search

When enabled, if the software detects insufficient point cloud data while

scanning weld seams on small step surfaces, it will automatically perform

an additional scan of the adjacent large surface area to assist recognition.

Non-interference zone

calculation for weld

When enabled, the system will automatically generate non-interference

toolpaths for partition plate units passing through manholes.
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11.1.5 Butt Weld Parameter

Figure 11-6 Butt weld parameter

The parameters are described in the following table:

Table 11-5 Butt Weld Parameter Description

Parameter Description

Gap Between Two

Surfaces

Sets the default gap for butt weld seams.

Height Diff Sets the default height difference between the two plates on either side of

the butt weld.

11.1.6 Search Parameter

Figure 11-7 Search parameter

The search (precision positioning) parameters are described in the following table:

Table 11-6 Search Parameter Description

Parameter Description

Single Weld Length To

Search

If the single weld length is shorter than this value, Refer Search will be used

by default.



CypWeld User Manual

www.bochu.com 110

Parameter Description

Series Weld Length To

Search

If the series weld length is shorter than this value, Refer Search will be used

by default.

Continuous Curve Smc Adjusts the toolpath transition distance before and after corners in

continuous curves. A smaller ratio results in sharper tool transitions.

Continuous-Curve-Search

Smooth Rate

Optimizes the scanning posture at corners during seam tracking. By

adjusting the motion trajectory in advance, it reduces self-occlusion of the

workpiece. Increasing this ratio appropriately can help mitigate occlusion

issues caused by initial positioning errors or delayed posture adjustment

during searching. Default value: 100%.

Multi Weld Search Mode Defines the seam searching mode for sub-passes in multi-layer multi-pass

welding.

Default Search Mode  Sets the default seam searching method for automatically generated

weld seams and manually edited weld seams. Options include Start

Spot Search, Tail Spot Correction, and Scan Search.

 When using Start Spot Search or Scan Search, enabling Auto Generate

Use Start Search When Vertical Up Wrapping allows the system to use

start-spot searching for vertical upward corner seams by default,

without searching the corners.
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11.1.7 Dual-bench Parameter

Figure 11-8 Dual-bench parameter

Only to positioners equipped with dual-bench. Details are shown in the following table:

Table 11-7 Dual-Bench Parameter Description

Parameter Description

Planning excludes barriers Allows the robot arm to move beyond the workable barriers during

path planning.

Hide Workable Barrier Hides the display of the workable barrier. Collision planning,

however, remains active.

Modify Current Worktable Barrier Adjusts the position of the worktable barrier.

11.1.8 Auto-generated Drawing Parameters

Figure 11-9 Auto-generated drawing parameters

The parameters are described in the following table:

Table 11-8 Auto-Generated Drawing Parameters Description

Parameter Description

Start point near the

robotic arm side

In the auto-generated weld seam function, the weld seam start point is

placed on the side closer to the robot by default.

Max adjustable distance Sets the maximum allowable adjustment distance between the start and

end points in the Procedure Table.
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11.1.9 Box Column Parameters

Figure 11-10 Box column parameters

 Minimum weld length: When generating weld seams on box column workpieces, this

parameter defines the shortest allowable weld seam length.

11.1.10 Scallop Parameters

Figure 11-11 Scallop parameters

 Auto scallop joint: When enabled, seams interrupted by scallops will be automatically joint.

During manual seam generation or automatic drawing (excluding tower-foot automatic

drawing and batch mode), the system sets the three-plane start/end points according to

the seam interruption length caused by partitions. This option is disabled by default. When

enabled, the default value is 25 mm.

11.2 Global Procedure Parameter

11.2.1 BreakPtLOC

Figure 11-12 Breakpoint location

The parameters are described in the following table:

Table 11-9 BreakPtLOC Parameter Description

Parameter Description

Check breakpoint

information before starting

processing

When enabled, the software will prompt a pop-up before each

processing cycle if breakpoint information exists, asking whether to

continue from the current position.
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Parameter Description

Set as maximum deviation

for breakpoints

Defines the maximum allowable TCP relocation distance when setting a

new breakpoint for reprocessing. This value must remain within a strict

safety range. Exceeding this distance may cause significant deviation

from the original weld seam position, resulting in collision risks.

11.2.2 Arc Tracking

Figure 11-13 Arc tracking

The parameters are described in the following table:

Table 11-10 Arc Tracking Parameter Description

Parameter Description

Enable logging for arc

tracing data

When enabled, the software automatically records arc tracking data during the

welding process (recommended).

Phrase delay in

sampling

After performing System Delay Measurement, the delay data is entered here to

compensate for the arc tracking sampling delay.
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11.2.3 Search

Figure 11-14 Search parameters

The parameters are described in the following table:

Table 11-11 Search Parameter Description

Parameter Description

Use the workpiece direction of

initial positioning

When enabled, Search (precision positioning)will only be applied

at the weld start point. The welding direction will be determined

by 3D model data and initial positioning results.

Use initial workpiece orientation for

intermittent straight welds

When enabled, during intermittent straight welds, the welding

direction will not follow Search (precision positioning) results, but

instead use 3D model data and initial positioning results.
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Parameter Description

Enable excessive search vector

deviation warning/Search vector

deviation warning threshold

When enabled, if the detected welding direction vector from the

precision positioning scan deviates from the model beyond the

set threshold, the software will trigger an alarm.

Use the radius from the drawing for

circle search

When enabled, circular weld paths (arc radius) will not be fitted

based on scan results but will follow model data. CAD/model

data consistency must be ensured.

Enable excessive search circle

radius deviation warning/Search

circle radius deviation threshold

When enabled, if the fitted circular radius from vision scanning

deviates from model data beyond the threshold, the software will

trigger an alarm.

Enable excessive search circle

center deviation warning/Search

circle center deviation threshold

When enabled, if the fitted circular center position from vision

scanning deviates from model data beyond the threshold, the

software will trigger an alarm.

Line segment spacing threshold In continuous welding with corner-seam positioning enabled, if

the detected corner position deviates from model data beyond

the threshold, the syoftware will trigger an alarm.

Recognize interruption When enabled, for discontinuous welds, the software will

automatically end/restart the arc before and after each gap,

skipping the interval to enable a continuous welding workflow.

Arc start offset Offset distance for starting the arc after an interruption in

discontinuous welds.

Arc end offset Offset distance for ending the arc before an interruption in

discontinuous welds.

Recognize gap  When enabled, the software can automatically detect gaps

between horizontal and vertical plates in fillet welds and

apply adaptive filling.

 On the weld seam editor page, when Fill Weld Gap is enabled,

the software will enforce scanning-based seam tracking for

gap recognition and filling during welding.
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11.2.4 Processing Flow

Figure 11-15 Processing flow

The parameters are described in the following table:

Table 11-12 Processing Flow Parameter Description

Parameter Description

Automatic handling options

for search failures

Defines the handling mode when fine positioning fails. The software

provides three options:

 Pop-up prompts to confirm manually: The operator manually selects

the next action (manual positioning/point-cloud selection/skip

seam/stop processing).

 Auto skip and process next welding: The software automatically

skips the current seam and proceeds to the next weld task.

 Alarm and Stop: The software immediately triggers an alarm and

halts processing.

Automatically re-scan once

when seeking fails

When enabled, if precise positioning fails on the first attempt, the

software will re-scan the same seam using the same method.

Automatic skip after weld

recognition failure

When enabled, if the precise positioning result is too close to the

worktable (below a defined threshold), the software will treat it as a

failure and display a prompt. This is applicable when the workpiece is

directly placed on the table surface.

Maximum recognition error

redundancy

Defines the maximum allowable distance between the precise

positioning result and the worktable.
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11.2.5 Select Weave Algorithm Type

Figure 11-16 Select weave algorithm type

 Weave of velocity planning method: When enabled, activates an optimized weaving motion.

By applying filtering, the weaving movement is stabilized and smoothed (recommended to

enable).

11.2.6 External Axis Filtering

Figure 11-17 External axis filtering

 Optimization of external axis welding start/stop: When enabled, improves external axis

filtering. In scenarios with frequent start-stop movements, this reduces vibration caused

by insufficient rigidity of the external axis (recommended to enable).
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11.2.7 Safety Point Update

Figure 11-18 Safety point update

The parameters are described in the following table:

Table 11-13 Safety Point Update Parameter Description

Parameter Description

Enable safety point remapping During arc-tracking correction, if the actual seam end position

deviates from the model beyond the set threshold, the software

will automatically offset the torch lift safety point to the

calculated position adjusted by arc-tracking results.

Allowed endpoint deviation threshold If the actual seam end deviates from the model end beyond this

threshold, the software will trigger an alarm notification.

11.2.8 Point Cloud Simulation

Figure 11-19 Point cloud simulation

The parameters are described in the following table:

Table 11-14 Point Cloud Simulation Parameter Description

Parameter Description

Enable Precise Positioning

Point Cloud Simulation

In Demo mode, external point cloud data can be imported for simulation

(for BOCHU R&D use only).

Enable Coarse Positioning

Point Cloud Simulation

In Demo mode, external point cloud data can be imported for simulation

(for BOCHU R&D use only).
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11.2.9 Touch Positioning

Figure 11-20 Touch positioning

Refers specifically to wire-based bevel touch sensing, not nozzle sensing. Before each use,

please perform Clean Torch_CutWire. The parameters are described in the following table:

Table 11-15 Touch Positioning Parameter Description

Parameter Description

Is Manual Touch Position Height

Set?

When enabled, the operator can manually set the touch sensing

height, i.e., the linear distance between the touch point and the

root of the bevel seam.

Multi-point Touch Seek Mode Provides two seam calibration methods along the weld direction:

 Start-End: Calibration is performed using only the seam start

and end points.

 Interval: Enables the Touch Seek Interval parameter, allowing

calibration at multiple points along the weld at defined

intervals.

Touch Seek Height When manual mode is enabled, defines the linear distance

between the wire touch point and the root of the bevel seam.

Touch Seek Interval Defines the spacing distance between multiple touch sensing

operations along the weld direction.

11.3 Point Cloud Reconstruction Parameter

For details, please refer to CypWeld Intelligent Welding Control Software User Manual -

System 3800 Edition.

https://drive.weixin.qq.com/s?k=AJEAqwcIAAcW3whjHg
https://drive.weixin.qq.com/s?k=AJEAqwcIAAcW3whjHg
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11.4 Seam Tracker Debugging Parameter

11.4.1 Roughlocate Parameter Setting

1. GlobalParams

Figure 11-21 Partial global parameters

The parameters are described in the following table:

Table 11-16 Partial Global Parameter Description

Parameter Description

Enable ROI-based background

filtering

Disabled by default. Enable when background point clouds cannot

be automatically filtered (e.g., excessive noise, high background

points captured, or the workpiece base plate is close to the

worktable).

Station A/B Switching If enabled, the ROI must be assigned to the corresponding

station.

Adjust ROI Before adjustment, an initial positioning scan must be performed.

The ROI is then selected based on the scanned point cloud.

Pose scoring: Ambiguity solution

difference threshold

If multiple registration results exceed the valid score threshold

and their score difference is below this ambiguity threshold, they

are treated as ambiguous results. The software will prompt the

user to select manually. Default: 0.03 (no change required).
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Parameter Description

Pose scoring: Outlier solution score

threshold

If registration scores fall between the valid threshold and outlier

threshold, the results are treated as outlier solution score, and a

prompt will appear. Default: 0.6. Usually no adjustment is

required; lower if initial positioning repeatedly fails.

Pose scoring: Valid solution score

threshold

Registration scores above this threshold are treated as valid, and

initial positioning succeeds directly. Default: 0.95 (no change

required).

2. TemplateParams

Figure 11-22 Template parameters
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The parameters are described in the following table:

Table 11-17 Template Parameter Description

Parameter Description

Template Type  Version (General): Templates provided with software installation. Not

included in parameter backups. Restored after each installation.

 Site (Dedicated): Templates created per machine. Included in parameter

backups and retained after software upgrades.

Scan Pose  Tilt scan: 45° scanning. Provides wider coverage and less reflection

sensitivity, but more occlusion. Suitable for narrow and shallow

workpieces.

 Vertical scan: Nearly perpendicular scanning. Less occlusion but

narrower coverage, more reflection-sensitive. Suitable for wide and

deep workpieces.

Laser Face Alignment

Height

Used for path planning to define the optimal viewing distance of the laser

plane.

 Align the center: Suitable for H-beams with central features.

 Align the top: Suitable for pipe assemblies, fuel tanks with features

located on the top surface.

 Aim at the workbench: Suitable for T-joints and assemblies with bottom

features.

Workbench plane offset Sets an upward offset relative to the CAD worktable height to filter out

background point clouds.

 No modification required if reference plate (e.g., H-beam web) is not in

contact with the workbench.

 Reduce offset if the reference plate is in direct contact with the

workbench (e.g., ship assembly).

Registration strategy Defines the method of generating feature points for registration. If the

reference plate includes a vertical plate, no modification is required.

 Automatic judgment/Non-parallel version/Parallel version: Uses

vertical plate point clouds.

 Vertical board + Reference Plate Contour: Uses both vertical plate point

clouds and horizontal plate contour point clouds.
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Parameter Description

Vertical board angle

threshold

Defines the allowable angular deviation (relative to Z-up axis) for vertical

plate recognition. Default: 15°. Increase for highly tilted plates.

Model reference board

segmentation range

Height difference range within which surfaces are considered coplanar.

Default: 5 (no modification required).

Minimum area ratio for

model reference board

Surfaces with an area ≥ given ratio of the largest extracted model board are

treated as a candidate reference board. Default: 0.95.

Minimum area ratio for

point cloud reference

board

Surfaces with an area ≥ given ratio of the largest extracted point cloud plate

are treated as a candidate reference plates. Default: 0.3.

Reference board

inflection point filtering

range

Point clouds above this threshold relative to the reference board are treated

as vertical board corner points. Default: 30. Reduce when thin lap plates

exist above the reference board.

Reference board

extraction algorithm

Algorithm for extracting reference board. Default: RANSAC.

Random sample

consensus threshold

Used when RANSAC is selected. Defines allowable vertical fluctuation of the

computed plane. Default: 10.

3D Pose Refinement When enabled, a secondary registration is performed after initial alignment

to correct minor pose deviations.

Bottom Surface Strictly

Aligned

If the digital twin model is already confirmed to match the actual workpiece

orientation, enable this option to reduce computation time and improve

accuracy.

Simulation PointCloud

RefPlate

During model-based reference plate search, the system uses a discretized

simulated point cloud form for reference plate detection.



CypWeld User Manual

www.bochu.com 124

11.4.2 Weld Recognition Parameter

Figure 11-23 Weld recognition parameter

The parameters are described in the following table:

Table 11-18 Weld Recognition Parameter Description

Parameter Description

CadBufData Enable CadBufData, to generate a buf model file for the vision system to acquire

model information.

DetectHoleArbitrary Enable scan-based search to detect previously welded holes.

OnlyEasyStep Enable recognition only for right-angle overlaps of single thin sheets.

3PErrorDis Threshold for the deviation between the start point recognized on three planes

and the model’s initial start point. Exceeding this threshold results in recognition

failure.



CypWeld User Manual

www.bochu.com 125

Parameter Description

3PGap Maximum distance allowed between point clouds of three planes. (See Figure

11-23: yellow and blue distances belong to 3-plane gap.)

2PErrorDis Threshold for the deviation between the start point recognized on two planes

and the model’s initial start point. Exceeding this threshold results in recognition

failure.

2PModelErrorDis Threshold for deviation when using the new 2-plane screening algorithm. When

enabled, this distance is used as the reference for initial positioning.

ErrorAngle Threshold for the angular deviation between the recognized point cloud plane

and the corresponding model plane. Exceeding this threshold results in

recognition failure.

StepErrorDis Threshold for the deviation between the recognized overlap start point and the

model’s initial start point. Exceeding this value results in recognition failure.

HoleMinL Minimum length for passing weld holes. (See Figure 11-24)

HoleMaxL Maximum length for passing weld holes.

GapMinL Minimum distance between non-weld seam plates.

GapMaxL Maximum distance between non-weld seam plates.

SaveParaToFile After adjusting any parameter, click SaveParaToFile to store the settings in the

parameter file.

RecoverParaAndSave Restore all parameters to default and save to the parameter file (overwrite

existing file).

Figure 11-24 Illustration of 3-plane gap



CypWeld User Manual

www.bochu.com 126

Figure 11-25 Minimum length of scallop

11.4.3 Butt Welding Search Parameter

Figure 11-26 Butt welding search parameter

The parameters are described in the following table:

Table 11-19 Butt Welding Search Parameter Description

Parameter Description

MaxCoarseErrorDis/mm Threshold for the deviation between the recognized overlap start point

and the model’s initial start point. Exceeding this value results in

recognition failure.

MaxCoarseErrorAngle/deg Threshold for the angular deviation between the recognized seam and the

model seam direction. Default value is recommended.
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Parameter Description

MaxCoarseErrorLength/mm Threshold for the length deviation between the recognized seam and the

model seam. Default value is recommended.

11.4.4 Groove Debug

Figure 11-27 Grove debugging parameters

The parameters are described in the following table:

Table 11-20 Groove Debugging Parameter Description

Parameter Description

Groove Width Bias (mm) When recognizing a single-frame groove, the allowable groove width is

within the range (Width - Z, Width + Z), where Z is this tolerance value.

Default recommended.

Thickness Bias (mm) Maximum deviation allowed between the recognized plate thickness and the

standard value. Default recommended.

Thickness Difference

Bias (mm)

Maximum allowable misalignment; exceeding this is considered an

abnormal groove. Default recommended.

Groove Angle Bias (°) Tolerance range for groove angle recognition to determine if it matches the

expected groove. Default recommended.
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Parameter Description

Track Smooth Size (mm) Smooths the final weld trajectory to remove jitter; higher values produce

smoother curves.

Kalman Parameter Gain parameter for the Kalman filter applied to the recognition results.

Single Frame Smooth

Size (mm)

Applies local smoothing to weld features in each point cloud frame.

Contour Partition Size

(mm)

Used to segment contours in the point cloud for subsequent feature

extraction.

Max Miss Length (mm) If a weld feature segment is missing less than this distance, interpolation is

attempted; otherwise, it is treated as a break.

Joint-to-Surface

Threshold (mm)

Determines whether a point is considered a weld point. Points closer to the

top surface of the box-type column than this distance are considered

obstacles requiring interruption.

Outlier Filtering Level (0

to 9)

Controls the filtering strength for outlier points in the point cloud; higher

levels remove more points.

Boss Point Threshold If the ratio of boss points in an area exceeds this value, the area is judged as

non-weld.

Thickness Cut By CAD The system automatically recognize all plates. The plates exceeding the

preset recognition thickness will be ignored.

Use CAD Thickness Uses the pre-set drawing plate thickness as a reference for recognition.

Use CAD Angle Uses the drawing groove angle for matching and recognition.

Detect Solder Joints Enable when recognizing weld points; default is disabled.

Detect Boss Only Only recognizes boss features, not weld seams; default is disabled.
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