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Foreword
Thank you for using BOCHU TubePro Laser Cutting System Software.

TubePro is a laser cutting software for tubes, featuring high precision and high efficiency. Its main

functions include Visual Calibration, Parameters Modification, Custom PLC, Simulation and accurate

control for laser cutting.

For the actual processing, TubePro must work together with the motion control card. TubePro will

run in Demo mode when used on a PC without motion control card.

Please note that this manual provides software instructions of the two-chuck machines. For other

tools or details required advanced permissions, please refer to other manuals or contact our technical

support. Due to the continuous update of system functions, the functions you are using may differ in some

aspects from the statements in this manual.

If you have any questions or suggestions, feel free to contact us!

Convention Symbol Explanation

Notice: Supplementary or explanatory information for the use of this product.

Caution: If not operated as specified, it may result in minor physical injury or equipment damage.

Warning: If not operated as specified, it may lead to death or serious physical injury.

Danger: If not operated as specified, it will cause death or serious physical injury.

Disclaimer

The machine tool operation and laser cutting quality have something to do with the material being

cut, the laser used, the gas used, the pressure and the parameters you set. Please set the parameters

according to your cutting process requirements! Improper parameter setting and operation may lead to

poor cutting effect, damage to laser head or other machine components and even personal injury. TubePro

has tried its best to provide various protection measures. Laser equipment manufacturers and end users

are supposed to abide by operating procedures to avoid injury accidents as possible as they can.

BOCHU shall not be liable for any direct or indirect losses arising from the following circumstances:

damages caused by improper use of this manual or the product, failures to comply with safety operating

procedures, or force majeure events such as natural disasters.

张静华
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Additionally, operational equipment carries inherent risks. Users are obligated to implement robust

fault-handling mechanisms and safety protections. BOCHU assumes no responsibility for any incidental

or consequential losses resulting from such risks.
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Chapter 1 System Selection Guide

TubePro 2-Chuck is specially designed for efficient tube processing, supporting for functions

including Dodge, Interpolation Follow, and Holder follow, and capable of processing tubes of multiple

types. The available systems of 2-Chuck are shown below. You may refer to this table or contact the

BOCHU for system selection.

Table 1-1 TubePro 2-Chuck System Selection

Functions 3000S 3000DE-L 3000DE-M 3000DE-G 5000B 5000BH

Real-time

EtherCAT
- √ √ √ √ √

Dodge √ √ √ √ √ √

Interpolation

Follow
- √ √ √ √ √

BLT Intelligent

Cutting Head
- - √ √ √ √

Holder Follow - - - √ √ √

Chuck Size (>

120 mm)
√ √ √ √ √ √

Hardware Board

Master

Station

Card

Master

Station Card

Master

Station

Card

Industrial

Control

Computer

Industrial

Control

Computer

Caution: 3000DE-M + Holder Follow= 3000DE-G

张静华
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张静华
大写

张静华
follow



TubePro User Manual for Two-Chuck Machines

www.bochu.com.en 2

Chapter 2 Preliminary Debugging

Preliminary debugging is used for the first power-on debugging. After mechanical assembly is

completed, the preliminary debugging can ensure that functions such as each motion axis and holder can

be used normally.

2.1 Debugging Procedures

The main procedures are shown below:

Figure 2-1 Main procedures for debugging

2.2 Procedures

Users shall configure the parameters of height controller and the basic parameters of Axis X, Y, Z, A,

and B in Machine Config Tool before opening TubePro.

For Travel range, a rough value can be set in the first. For the Pulses, Limit logic, Servo alarms,

Return origin direction, Return origin signal, users should fill in based on the actual situation.

Figure 2-2 Axis configuration

张静华
上面用的是holder

张静华
配置调高器的基本参数，而不是配置调高器

张静华
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2.2.1 Return Origin

Open TubePro, and visit with Admin mode for following debugging.

Manual jog each axis at low speed. If a soft limit alarm occurs, temporarily disable Soft limit

protection in the Jog Quick Settings. If a Return Origin alarm occurs, use the Ignore Origin Alarm

option in the drop-down menu of the Return Origin button.

Figure 2-3 Jog settings

After confirming normal jog, open Motion control monitor under the Monitor of Tools menu.

Trigger the origin and limit switches of each axis sequentially (do not jog the axis during this step). For

photoelectric switches, use a baffle to block the light beam. Observe the corresponding signals on the

monitoring interface.

After verifying that the origin and limit switches are functioning properly, you can proceed with the

Return Origin operation.

During the first debugging session, perform single-axis Return Origin tests first. Click the dropdown

button for Return Origin and execute single-axis Return Origin for the Z/X/Y/B axes sequentially.

After confirming successful Return Origin for all individual axes, configure specific Return Origin

actions in the Return Origin according to the machine model. Subsequently, you can directly click All

Return Origin button to perform simultaneous origin returning for all axes.

2.2.2 Holder Debugging

If holders are installed, estimate the Y-axis lowering position parameters for each holder before

closing the software to configure them: After performing Return Origin, jog the Y-axis to a position

where each holder is safely distanced from the main chuck. Considering parameters like holder

lifting/lowering duration and rapid travel speed, ensure no collision occurs during operation. Record the

张静华
删除

张静华
增加冠词a

张静华
全文的人称需要统一，前面存在users。

张静华
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current Y-axis value as a reference for the holder’s lowering position parameter.

After recording all holders, close the software and open the Machine Config tool. Navigate to the

Holder settings page to input the parameters. After configuring holders in the tool, click Manual Debug

in the menu bar to open the Debug chuck, holder and single axis menu.

Figure 2-4 Manual debugging

If the holder gas main valve output is configured, Disable Holder Function will be enabled by

default. Disable this manually to proceed. Holders with Y lowering position parameters greater than the

current Y coordinate are considered safe and can be manually raised/lowered on the debugging page.

Use a stopwatch to measure lifting/lowering time, then refine the default in-place time and lowering

position parameters based on actual performance.

2.2.3 Chuck Debugging

After configuration, the chuck can be controlled to clamp/unclamp in Manual Debug. Measure the

time required for the chuck to clamp and unclamp with a stopwatch, and configure this time as the default

in-position time for chuck clamping and unclamping.

After successful debugging, load and clamp the tube by clicking the chuck's clamp/unclamp buttons.

If a holder is configured, it can be used in coordination.

张静华
时间，单数，加了s更像是次数。
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2.2.4 Capacitance Calibration

Jog the X/Y/B axes to position the rectangular tube below the cutting head, ensuring the upper

surface of the tube is approximately horizontal. Then jog the Z axis to bring the cutting head nozzle close

to the tube surface. Click Calibrate Capacitance. A safety confirmation dialog will appear—click OK to

start calibrating the height controller.

Figure 2-5 Capacitance Calibration

2.2.5 Calibrate B-axis

Step 1 Jog the X/Y/B axes to position a standard rectangular tube (without chamfers) below the cutting

head nozzle, ensuring the tube’s upper surface is approximately horizontal.

Figure 2-6 B-axis Center Calibration



TubePro User Manual for Two-Chuck Machines

www.bochu.com.en 6

Step 2 Open Calibrate B A,xis Center window enter the dimensions of the rectangular tube, and click

Start. After the calibration is finished, click Save.

Figure 2-7 Calibrate B-axis center

Notice:

1. A standard rectangular tube without chamfers must be used. Chamfers will affect the accuracy of

B-axis calibration.

2. Before calibrating the B-axis center, ensure accurate and reliable coordinates for the X/Z/B

axes—perform a full return to origin for all axes beforehand. Calibrate the B-axis center only once

during the first debugging; no need to redo it if the mechanical structure is not moved afterward.

Additionally, after configuring basic parameters such as laser, gas, and alarms, the machine will have

basic processing capabilities.

张静华
图文不一致，界面显示的是B Axis

张静华
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Chapter 3 Quick Start

3.1 Quick Start

Quick start for machining with debugged machines. Before processing, it should be confirmed that

the system has returned to the origin, and the capacitance calibration and pressure calibration are done.

Otherwise, please execute the operations including returning to origin, calibrating the capacitance, and

calibrating the B-axis via a standard rectangular tube without chamfers.

The processing procedures of TubePro is shown below:

Figure 3-1 The processing procedures of TubePro

3.1.1 Import File

Click the Open menu and select the *.zx or *.zzx file to be processed. When opening a drawing, the

right side of the page previews the processing graphics and dimensions.

Figure 3-2 Opening a drawing

张静华
有缩进

张静华
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3.1.2 Set Techniques

After import, use the right-side toolbar to configure layer properties and layer processes for the

graphics.

Click the Layer button to set technique parameters for layers, including cutting, piercing, tube corner,

and bevel processes.

Figure 3-3 Set techniques

3.1.3 Start Processing

Before starting, center the tube, then click Start in the operation panel to begin processing the

graphics. During processing, the part’s progress will show in the status bar.

Figure 3-4 Start machining

张静华
给不同的图层吧，layers
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3.1.4 Alarm Introduction

During operation, if an alarm or warning occurs, relevant information will appear in the top alarm

status bar, with the alarm time and details shown in the bottom alarm description area.

Figure 3-5 Alarm information

Caution:

1. For axis limit alarms, check axis status via Tools→Motion Control Monitor to troubleshoot.

2. For I/O port-related alarms, check input status via Tools→ I/O Board Monitor to resolve issues.

张静华
删除
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3.2 Software Installation & Uninstallation

Close antivirus software and any running TubePro or Machine Config tool before installing.

Double-click the installation package and follow prompts to install.

Figure 3-6 Install TubePro

Caution: Overwrite installation retains previous parameter configurations. To clear all data,

please uninstall TubePro.

During uninstallation, choose whether to delete user data. If Uninstall user data is checked,

mechanical settings, PLC configurations, and technique parameters will be erased.

Figure 3-7 Uninstall TubePro

Caution: By default, deleting user data is checked. For software upgrades, it is recommended to

perform an overwrite installation. Use uninstallation only if data loss or file corruption occurs.

张静华
前面是Tool
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Chapter 4 Software Functions

4.1 Quick Access Toolbar

Quick Access Toolbar includes Lead-in Line, Start Point, Micro-joint, Reverse, Cooling Point,

Weld Seam Compensation, Center, Nudge Graphic, Clear, Display Mode, Views, etc.

Table 4-1 Quick Access Toolbar

Icon Name Description
Select lines Select the specified graphic. If you click the part area, you can select all paths

of the part at once (the front face of the co-edge part is not selected).

Drag Allows you to drag the graphic to view. Alternatively, you can drag the

graphic to view it by pressing and holding the Ctrl+ scroll.

3D view. It allows you to rotate the view for 3D graphics. You can also enter 3D view

mode by holding and dragging the mouse. Press and hold the Shift + scroll,

then drag the mouse to rotate the graphics around the central axis of the tube.

Fit Window Adjust the display of the graphic to fit the current window.

Compensation Set kerf compensation for the selected graphic or all graphics. When

compensation is added, the original graphic changes to white, the

compensated graphic changes to the original layer color. The actual cut will

follow the compensated trajectory.

In/Out To choose cut inner or outer, which decides the leadline and compensation

are inside or outside the graphic.

Lead-in Line Set the lead-in/out line for the selected graphic or all graphics. You can set

the lead line type, length, and angle, and add a cooling point.

Start point Set the starting position of each trajectory in the graphic.

Microjoint Adds a small distance joint on the graphic. The laser will not cut on the place

with micro-joint. You can insert multiple microjoints by continuously

clicking on the graphic. Hold down the Shift and clickMicrojoint to delete it.

Gap Leave a segment uncut at the end of the cutting path (used in C-shaped co-

edge cutting).

Seal Used to remove gaps and overcuts, restoring the gap/overcut-free state.

Reverse Reverse the cutting direction of the machining graphic paths.

Cooling point. The laser is off and the gas is blowing at the cooling point.After the cooling

张静华
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Icon Name Description
point delay, the processing continues. The cooling point delay is configured

in the global parameters.

Weld Seam

Compensation

Set whether to use weld seam compensation for the graphic cross-section

position.

Center Set the starting point of the graphic as the centering point.

 Click Center for a single selected graphic to set its starting point as the

centering point.

 Click Center for multiple selected graphics to automatically set

centering points. TubePro will add centering points to appropriate

graphics based on the configured minimum centering point spacing.

When processing reaches a centering point, the system will

automatically center first and then continue processing.

Single Face

Center.

Set the one-side centering point for trajectories in the graphic. Square tubes

and L/C steel profiles support adding one-side centering points, while cut-off

lines and side holes do not.

Tube Profile

Measurement:

Allows direct addition of the tube profile measurement function to a

trajectory. After successful addition, a Tube Profile Measurement label will

appear on this bevel trajectory. Supports automatically setting profile

measurement points for nesting drawings.

Nudge Move the selected graphics slightly along the X or Y-axis direction for easy

debugging.

Clear You can select Clear Compensation/Leadline/MicroJoint/Cooling

Point/Nudge/All.

Countersink

Bevel

Allows modification of toolpaths for parts with Countersink Bevel.

Join Nearest. Combines multiple curves into a single curve based on the given merging

precision.

Break Curve. Divides graphics or part areas along a specific curve.

Intersect Hole Regards the curve as a planar curve in the XY plane, used for bevel cutting of

intersecting lines.

Display Choose whether to show open graphics/processing sequence/path start/path

direction/Microjoint/travel path/section/surface rendering/normal vector/

highlighted leadline /cutting head model.

View Select the view mode.

 You can select Default/Top/Main/Bottom/Back/Right/Left/Southwest

张静华
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Icon Name Description
Isometric/Northeast Isometric/Southeast Isometric/East-West

Isometric/Northwest Isometric view. View refresh can be switched

on/off;

 You can set the view to reverse (rotate the drawing 180° along the

Z-axis) in cases where the clamping method of non-symmetric pipe

materials such as angle steel and profiled steel is inconsistent with the

drawing on the YOZ. In this situation, there is no need to remove and

re-clamp the tube.

 You can just reverse the view to ensure the actual tube orientation is

consistent with that is in the drawing.

Measure After clicking Measure, left-click the two points to be measured on the

graph. The distance between the two points and the absolute distances in the

X/Y/Z directions will be displayed in the log.

Undo Click Undo, and you can withdraw the previous operation.

Redo Click Redo, and you can restore the previous operation.

张静华
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4.2 Machining Control

As shown in the figure,Machining Control is on the right side of the interface, including Burst, Jog,

Debug and Process, whose control parameters can be changed in settings respectively. The below shows

the details about these four operation zones.

Figure 4-2 Machining control

张静华
无需加粗和斜体
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4.2.1 Burst

Figure 4-3 Burst control panel

The parameters of Burst Control is shown below:

Table 4-2 Burst Control

Parameter Description
Shutter Turn on the Shutter manually before processing.

Aiming
Used as the pilot light. the Aiming can inspect the optical path, verify the laser connection,

and position the cutting head.

Laser
Laser pulse firing Laser. With Shutter on, left-click for single burst, and right-click for

continuous shooting.

Follow Set the height controller for following levels.

Blow
Click Blow for air blowing when no tube is being processed. Automatic air blowing is

activated during processing, with real-time display of the air blowing status.

Air Select blowing gas type.

Quick setting parameters for Laser On and Gas On

Table 4-3 Laser On and Gas On Parameters

Parameter Description
Peak power Peak power of burst laser.

PWM duty circle Set the PWM duty circle when bursting.

Pulse frequency Set the carrier frequency of the PWM modulation signal, i.e., the number of

light emissions per second. A larger value indicates more continuous light

emission.

Button blow pressure Set for the blowing gas pressure.

张静华
引导光的翻译

张静华
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张静华
激光器点射的翻译

张静华
删除

张静华
表格里的参数名称，首字母的大小写不统一。有时和界面一致，有时不一样。



TubePro User Manual for Two-Chuck Machines

www.bochu.com.en 16

4.2.2 Jog Control

Figure 4-4 Jog control panel

The parameters of Jog Control is shown below:

Table 4-4 Jog Control Parameters

Parameter Description

Jog panel
Jog or step the X/Y/Z/A/B axes. After configuring general-purpose axes, jogging or

stepping for general-purpose axes can also be set.

LOW/HIGH The option to set Low or High speed for Jog or Step.

Step
If enabled, the cutting head will move by PWM duty circle of designated distance, or it

will move by Jog.

Focus

If an electric focusing cutting head is configured, focus jogging is available. The five

buttons represent: Locate to Specified Point, Negative Jog, Positive Jog, Return Origin,

Stop.

The specific settings are as follows:

Table 4-5 Jog Quick Settings

Parameter Description
Jog high speed Set the high-speed jogging/stepping speed for X/Y/A/B axes and

general-purpose axes.

Jog low speed Set the low-speed jogging/stepping speed for X/Y/A/B axes and

general-purpose axes.

Step length Set the stepping length of X/Y/A/B axes.

Soft limit protection Set whether the system enables soft limit protection. The soft limit travel is

set in Machine Config tool.

Show X/Y jog direction After checking the box, the jog icons for XY will change from arrows to

±XY directions to indicate the jogging direction.
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4.2.3 Debugging Panel

Figure 4-5 Debugging Panel

The parameters are shown below:

Table 4-6 Debugging Operation

Parameter Description

Sample Cut

Used for non-full-tube processing scenarios. After completing the processing, the

machine will stop at the end point, neither returning to the zero point nor executing

the PLC (Programmable Logic Controller) command for file termination. This

mode can be enabled when processing individual parts.

Dry Run
The machine tool moves according to the graphic, but there is no laser emission, no

follow, and no gas blowing.

Return Center The machine’s X, B, Z, and A axes move to the program zero point.

Go zero
The machine moves to the graphic zero point, with all X, Y, Z, B, and A axes in

motion.

Break point

location

After an error triggers an alarm and stops processing, use Break point location to

return to the exact position where processing halted, then resume operations.

Forward/Backward
After breakpoint positioning or pausing, click Forward or Backward to adjust the

processing position.

Manual Center
For irregular-shaped tubes where automatic centering fails, manually set the

deviation between the tube's drawing center and rotation center.

Automatic Center

Automatically measure tube deviations to ensure trajectory accuracy during

processing. The software selects the appropriate centering method based on the

imported drawing type.

Debugging Quick Settings.
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Table 4-7 Debugging Quick Settings

Parameter Description
Forward/Backward

distance.

Set the distance for forward/backward adjustments. Use it during pause to

position the location.

Forward/Backward speed Set max moving speed for Forward/Backward.

B-axis backward/forward

max speed

Limit the maximum speed of the B-axis during forward/backward

operations.

Fine edge-finding speed Set the speed for precise edge detection during B-axis centering.

Rough edge-finding speed Set the speed for initial edge detection during B-axis centering.

Don’t prompt after start
Suppress the Resume Processing pop-up when restarting via the Remote

Control.

Set centering follow height
When checked, allows setting the cutting head height during centering

operations.

Centering Plan

Configuration

The software suggests suitable centering methods based on the current tube

type.

4.2.4 Processing Control Panel

Figure 4-6 Processing control panel
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The parameters are shown below:

Table 4-8 Processing Control Panel Parameters

Parameter Description

Start
Start machining. * indicates modified graphic parameters; A =Auto Loading;

F = Auto Feeding; L = Cycle Processing.

Pause Halt processing. Changes to Quick Resume, which skips piercing when resumed.

Continue Resume processing, including piercing if configured in graphic parameters.

Stop Stop the current system command.

Cycle and Production detailed settings.

4.3 File Menu

4.3.1 About

Click File → About to view: Program version, Release date, Control card model, Follower type,

Laser model, License expiration date

Figure 4-7 About
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4.3.2 Parameter Backup & Restore

 Backup: Generate a .cfgpkg file via File→ Parameter Backup.

 Restore: Double-click the backup file, select parameters to restore, and click Recover.

Figure 4-8 Parameter backup and restore

4.4 Return Origin and Machine Calibration

The drop-down menu for returning to origin are shown below:

Figure 4-9 Return origin settings
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You can configure different origin return methods for specific machine models.The drop-down menu

allows selecting independent origin return for axes: Y1, Y2, B1, B2.

Figure 4-10 Return origin parameters

If Return origin alarm alert at startup is enabled in Advanced Configuration of Machine Config

tool, the alarm will trigger on startup and must be cleared via origin return. In Admin mode of the

software, you can click Ignore Origin Alarm to suppress this alarm, allowing continued debugging

without returning origin. Please ensure personal safety and equipment safety during this operation.

Figure 4-11 Force origin alarm

The parameters are shown below:

Table 4-9 Return Origin Parameters

Parameter Description

Single axis returns

origin (Z-axis first)

To ensure the safety of the cutting head, check this option to make the Z-axis

(height controller) return to origin first before single-axis return to origin for

X/Y/A/B axes. F indicates the automatic feeding function is enabled; L indicates

the cycle processing function is enabled.
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Parameter Description

All return origin

(include B-axis)

Not checked by default. Do not check this for machines without B-axis origin

switches; for dual-drive B-axis machines with separate origin switches, it is not

recommended to check this to prevent tube twisting caused by forgetting to

unload the tube during return to origin when B-axis independent return to

origin after uncoupled is also checked.

All return origin

(include Y-axis)

Not checked by default. Check this option if you want the Y-axis to return to

origin together during all axes return to origin. It is recommended not to check

this to avoid the tube falling off the middle chuck or sagging due to gravity after

clamping, when performing All return origin.

Y-axis return origin

(holders down first)

Checked by default. For safety, holders should be in the lowered state during

Y-axis return to origin to prevent collisions.

Return origin (include

focus axis)

When checked, the focus axis will return to origin first during the first return to

origin after software startup to ensure correct focus position.

Return origin (holders

first)

To prevent coordinate errors, checking this ensures all holder axes return to

origin first, avoiding chuck collisions with holders.

B/Y axis returns

origin (Check chuck

status in advance)

When checked, if both the main and middle chucks are clamped, independent

B/Y return to origin is not allowed. This prevents the tube from being pulled out

or twisted while clamped.

Y-axis return origin

(Check chuck status

in advance)

Check this option if Y1 and Y2 axes need independent return to origin. Y1 and

Y2 axes must have separate origin switches or limiters set.

B-axis return origin

(decoupled)

If checked, ensure the chuck is unloaded before return to origin. The B-axis will

perform independent return to origin and retract by their respective set distances,

with inconsistent angles between chucks during the process, which may cause

tube twisting or serious damage if clamped. If unchecked, all B-axes move

synchronously during return to origin.

Enable Before

ReturnOrigin PLC of

Y-axis

Checked by default. The Y-axis will execute PLC before Return Origin and

PLC after Return Origin during return to origin.

Enable Before

ReturnOrigin PLC of

X-axis

Checked by default. The X-axis will execute PLC before Return Origin and

PLC after Return Origin during return to origin.

All return origin

(include A-axis)

Not checked by default. Check this option if you want the A-axis to return to

origin together during full return to origin.
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4.4.1 Capacitance Calibration

Before calibrating the height controller, jog the cutting height, and make sure the nozzle

approximately 2 mm above the metal tube surface. Click Capacitance Calibration in the software and

wait for successful calibration. A calibration result showing Smoothness: Excellent, Stability: Excellent

indicates success.

Figure 4-12 Sampling range of Capacitance Calibration

4.4.2 B-axis Center Calibration

Once the mechanical structure is fixed, the B-axis has a fixed rotation center. Calibrating the B-axis

center determines the coordinates (X, Z) of this center on the XZ plane. Use a standard rectangular tube

without chamfers for calibration. Ensure the X, Z, A, and B axes have completed return to origin. Position

the cutting head nozzle above the standard tube, enter the tube’s width and height, then click Start. Save

and exit after calibration is complete.

Figure 4-13 Calibrate B-axis Center
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The parameters are shown below

Table 4-10 Calibrate B-axis Center Parameters

Parameter Description
Rectangular Tube

Dimensions

Set the width and height of the standard rectangular tube. It is recommended to use

standard rectangular tubes without chamfers.

Exclude beam

offset

Set the beam spot offset error of the current cutting head.

Application Scenario: TubePro measures the B-axis center based on the nozzle

center. If the piercing hole cut has deviations due to the laser beam spot not being at

the nozzle center, divide the deviation by 2 and enter it as the beam offset.

Result Displays the mechanical rotation center coordinate value.

Enable Special

B-axis Center

If the machine tool has a special structure (e.g., 7-Axis Delivering model or middle

chuck dodge model) where the mechanical rotation center changes during cutting, a

special B-axis center can be pre-calibrated. The default B-axis center is still used for

normal cutting. When the mechanical rotation center changes, the special B-axis

center can be enabled via PLC to improve cutting accuracy. The Copy + Save button

copies the B-axis center values.

Save/Cancel
Save: Records the measurement result as the B-axis center. Cancel: Discards the

changes without saving.

4.5 Manual Debug

TheManual Debug page is shown below:

Figure 4-14 Manual Debug
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4.5.1 Chuck Debugging

Before clicking chuck Clamp/Unclamp on theManual Debug page, use a stopwatch to measure the

time required for the chuck to clamp and unclamp. Then configure this time as the Default in-place time

for chuck clamping and unclamping in Machine Config tool. After configuration, test whether the

in-place time is set reasonably.

The manual debugging interface displays chucks configured in Machine Config tool; unconfigured

chucks are hidden.

The chuck pressure ratio corresponds to the chuck pressure auxiliary DA in the Machine Config tool,

which adjusts clamping pressure after configuration.

Figure 4-15 Chuck air pressure auxiliary DA Pport

Click Clamp/Unclamp to actuate the corresponding chuck. After the default in-place time, the button

turns green to indicate the current chuck status.
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4.5.2 Holder Debugging

Before debugging holders, configure the corresponding lowering position parameters for each holder

in Machine Config tool. Only holders with Y lowering position parameters greater than the current actual

Y coordinate are considered safe and can be manually raised/lowered on the manual debugging page.

Figure 4-16 Holder debugging

If a holder gas main valve output port is configured in Machine Config tool, Disable holder is

enabled by default. You should disable it manually to start holder debugging.

4.6 Holder Follow

If follow holders for loading are configured, a Holder Follow icon will appear in the function

debugging area. Click Holder Follow to enter the debugging page, where you can perform jogging, origin

returning, and holder calibration to enable coupled follow during processing.

Figure 4-17 Holder Follow

Notice: the FSCUT3000DE-L does not support Holder Follow.
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4.7 Monitor

4.7.1 Height Controller Monitor

Click Tools→Monitor→Height Controller Monitor, and you can see the real-time capacitance,

capacitance curve and capacitance temperature drift caused by heat, as shown in the following figure:

Figure 4-18 Height controller

On the Calibrate page, you can calibrate the capacitance, adjust the rigidity level, and check the

history record of capacitance calibration.

Height Controller Monitor page is consisted of the parameters to adjust the height controller. After

clicking on Unlock Parameter, you can modify the parameters. After modification, you must clickWrite

In Parameter to save and apply the modified parameters.

Figure 4-19 Detailed Parameter
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Table 4-11 Height Controller Parameter Table

Parameter Description

HitPlate alarm delay

in Travel/Cut/Pierce

When the system is in Stop, Travel, Cut or Pierce status, if HitPlate duration

reaches the delay time you set, then the cutting head will automatically lift up for

protection and give alarm signals. When this value is set to 0, the hit-plate alarm

will no longer be triggered in the Stop/Travel/Cut/Pierce state.

Follow error

Maximum follow error allowed by the height controller. After the cutting head

follows in place, once the follow error exceeds this set value as the cutting head

moves out of the tube boundary or the tube shakes violently, it will give a Follow

deviation alarm.

Follow error delay
Set Follow Deviation Alarm filtering time. Set it larger to allow longer follow

error time for better anti-interference capability.

Local capacitance

drop

When local capacitance diminished exceeds this set value, TubePro will give this

alarm.

Vibration

suppression

It is capable to suppress the vibration caused by the cutting airflow on the tube

with weak structural rigidity so as to reduce the cross-section wavy lines. Also the

vibration from airflow and surface slags.

Suppression time

It can determine the intensity of Vibration suppression, and a larger value will get

stronger suppression effect but slower controller response. The default value is 20

ms, and the recommended range is 5 ~ 50 ms.

Follow level

The Follow Level ranges from 1 to 30, and the default is 17. A higher level brings

less average error and quicker follow motion, also stronger Follow capability on

the tilted tube. However, if the gain is too strong, the system will generate

self-excited oscillation. You can automatically acquire a proper level by auto

adjust.

Return origin speed The speed for returning origin.

Z-axis stepback A retreat distance from the origin switch, set as the Z-axis coordinate origin.

Reset and go zero

ref
Whether to go to Zero Ref. after Return Origin.

Z travel range The stroke of Z-axis. (downward is negative).

Dock position Dock coordinate for Z-axis.

Soft limit Whether to enable Soft Limit Protection for the height controller.

Travel Speed Travel speed of the height controller.

Travel Acceleration Height controller travel acceleration.

Jog high speed Set high speed parameter for Jog.

Jog low speed Set low speed parameter for Jog.
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4.7.2 Motion Control Monitor

Click Tools→Monitor→Motion control monitor on the top bar of TubePro, and you will see the

window below:

Figure 4-20 Motion axis monitor

On theMotion Axis monitoring page, you can view the enabled status, alarm status, hard limit status,

soft limit status, origin returning switch status, pitch compensation status, command position, feedback

position, mechanical coordinates, and motion speed of each servo axis. You can also send servo

enable/disable commands, pulse debugging commands, clear coordinates, and clear dual-drive alarms.

The specific parameters are as follows:

Table 4-12 Motion Axis Monitor Parameters

Parameter Description
Axis No. The configured physical axis number.

Encoder feedback Servo encoder feedback value. (Unit: pulses.)

Command position Command position, unit: pulses.

Mechanical

coordinates

Mechanical coordinates, i.e., system command coordinate position, unit: mm or

rad.

Motion speed Real-time feedback speed of the current servo.

Servo raw feedback Records the feedback position of the servo motor, unit: pulses.

Servo alarm state Current alarm status of the servo.
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Parameter Description
-/+ limit switch Current input status of negative/positive hard limit switches.

Origin switch Current input status of the Return Origin switch.

-/+ SoftLimit switch Current negative/positive Soft Limit input status.

Pitch compensation
Only supported for X and Y axes, and used for detection if pitch error

compensation is enabled.

Servo on Click to enable or disable servo power.

Pulsing In the system stop state, specified pulses can be sent for testing.

Clear dual-drive error. Clear the errors of dual-drive.

Set mechanical

coordinates to 0
Set the current coordinate of Z-axis as zero.

On the page of Status monitoring, it is possible to view more low-level kernel status information,

such as mechanical coordinates, program user coordinates, and G-code instruction information, etc.

Figure 4-21 Status monitoring

On the Speed Constraints page, you can directly view the constraint configurations for the speed and

acceleration of each logical axis.

Figure 4-22 Speed Constraints
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4.7.3 IO Board Monitor

Click Tools→Monitors→IO Board Monitor, and you can see the window shown below:

In IO Board Monitor interface, you can select a specific board ID on the upper left, and test inputs

and outputs, monitor inputs status, adjust PWM and DA signals and check DA sampling results etc.

Figure 4-23 IO Board Monitor
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4.7.4 Realtime Curve Monitor

Click Tools→Monitors→Realtime Curve Monitor, and you can see the window shown below:

Figure 4-24 Realtime Curve Monitor

Realtime Curve Monitor can accurately sample the command position, command speed, feedback

position, feedback speed, feedback torque, command position deviation, double-drive position deviation,

buffer number and BCS height. You can select four signals for each monitoring, and all logic axes and

functional axes are included. The monitoring result can be displayed in curve. By default, there will be

four signal curves which can be selected as needed by clicking Signal Name at the bottom. You can also

zoom a certain range of the curve by selecting.

Vertical axis zoom of the curve is achieved via the mouse wheel. Hold down the Ctrl and left-click to

pan the monitoring curve vertically/horizontally. The monitoring range of the curve in the window can

also be adjusted using Adapt Y or Adapt X.

Left-click and drag to select a region of the monitoring curve for zooming in to view details. Two

cursors (Pointer 1 and Pointer 2) can also be set on the curve to capture precise values at specific

moments. All monitored curves can be saved as *.csv files for data storage. You can open previously

saved *.csv files at any time to review the monitoring curves.
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4.7.5 Remote Control Features

Click Tools→Monitors→Remote Control Features, and you can see the window below. This

interface can display the configured extended functions and the effect of swapping the order of X and Y.

Figure 4-25 Remote Control Features
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4.8 Auxiliary

4.8.1 Quick CutOff

Click Tools→Auxiliary→Quick CutOff, and you can see the window below.

Figure 4-26 Quick CutOff

TubePro supports Quick CutOff for common tube types such as square tubes, rectangular tubes,

round tubes, triangular tubes, obround tubes, and flat steel, as well as some irregular tubes. However,

Quick CutOff cannot be used for channel steel, angle steel, or irregular tubes with unclosed or concave

cross-sections.

Quick CutOff will sever the tube clockwise or counterclockwise at the current Y-axis position. If

Start point centering is checked, a start point centering operation will be performed before cutting.

张静华
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4.8.2 Quick Align Tube Head

Click Tools→Auxiliary→Quick Align Tube Head, and you can see the window below. This

function is capable of finding the tube head automatically, and the cutting head finally stops at a certain

distance from the tube head.

Figure 4-27 Quick Align Tube Head

The parameters are shown below:

Table 4-13 Quick Align Tube Head Parameters

Parameter Name Description

Distance between

Chuck and Cutter

To prevent the follow-up head collision caused by the tube not extending below the

cutting head, the tube will be fed forward by a certain distance when performing

Quick Align Tube Head. The default parameter is 120 mm, which can be adjusted

according to actual conditions.

Tube front margin

After the cutting head moves outward to detect the tube edge, the Y-axis advances by

an offset distance in the positive direction to prevent vibration caused by processing

at the tube’s edge.

Follow distance The cutting head height when executing Quick Align Tube Head.
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4.8.3 Quick AI Weld Seam Detection

Click Tools→Auxiliary→Quick AI Weld Seam Detection, and you can set for operations after weld

seam detected.

Figure 4-28 Entrance of the function

This configuration performs the same effect as that in Machine Config tool. The changes of this

window will be synchronized to the configurations in Machine Config tool, and vice versa.

Figure 4-29 Quick AI Weld Seam Detection
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4.8.4 Multi-File Production

Click Tools→Auxiliary→Multi-File Production, and you can see the window below. You can open

the files of a certain location from Single input port or open the files of combined locations from

Multi-bit input.

Figure 4-30 Multi-File Production

4.8.5 Time Estimation

Click Tools→Auxiliary→Time Estimation, and you can see the window below:

Figure 4-31 Estimate Production Time
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Click Start, and the system will automatically calculate the time for the entire processing, and

display the time for cutting, traveling, piercing, and others.

4.8.6 Profile Correction

Click Tools→Auxiliary→Profile Correction, and you can see the window below:

Figure 4-32 Profile Correction

Profile Correction can be used when the tube to be cut is non-standard, applicable for square tubes,

rectangular tubes, angle steel, channel steel, and C-channel steel. These parameters directly modify the

contour holes on the tube surface without affecting the cutoff line.

4.8.7 Gas DACorrection

Click Tools→Auxiliary→Gas DACorrection, and you can see the window below:

Figure 4-33 Gas DA Correction
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The parameters are shown below:

Table 4-14 Gas DACorrection Parameters

Parameter Description
Gas selection Select the gas for correction.

Set data groups
Set the number of linear nodes for data—the more groups, the more accurate the

fitting.

Input DA value in

equal difference

Set the DA value automatic distribution according to the equal difference of the

groups.

DAOutput Output the DA value one by one.

4.8.8 Cycle and Production Settings

Click Tools→Auxiliary→Cycle and Production Settings, and you can see the window below:

Figure 4-34 Cycle and Production Settings
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You can set the production process in this window. The parameters of Cycle and Production

Settings are shown below:

Table 4-15 Cycle and Production Settings Parameters

Parameter Description

Optimize B-axis

rotation

If the B-axis uses an absolute encoder, overflow issues may occur. When checked,

the B-axis will move in the opposite direction during idle movement (when it does

not affect processing) to mitigate this.

Enable single-part

soft limit

detection

When the option is unchecked, clicking Start triggers a full-file verification to check

if the entire machining program will exceed the software limits (soft limits) during

processing. If any part of the program exceeds these limits, the machine will not

start. When the option is checked, the system performs a dynamic check only for the

next part in the queue.

Check center error

before production

When checked, the system will automatically detect excessive centering deviation

before machining. If the centering deviation exceeds 5 mm, a warning message will

be logged.

Y/B axes working

mode

In Floating Mode, processes start from the current position, treating it as the

machining origin. In Workpiece Mode, the specified start point in the current file is

adopted as the machining zero point, moving to that position before starting

processing. It is recommended to use Floating Mode for the Y-axis and Workpiece

Mode for the B-axis during processing.

In the Cycle Production Settings module, you can configure parameters for cyclic production. Cycle

demonstration processing is used in exhibitions to repeatedly machine graphics without laser emission for

demonstration purposes, or to complete full-tube cycle demonstrations with automatic loading/unloading

PLC systems.

In this module, you can:

 Select to enable or disable Cycle Production.

 Set the Cycle interval and Planned Cycles.

 View the current number of completed cycles and clear the data to zero.

 When the following options are checked, they will automatically clear the completed cycle count.

Save the configured cycle processing parameters when exiting the program.
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In the Production Plan module, you can specify the processing calculation method:

 Calculated by the number of parts processed.

 Calculated by the number of times the file is processed.

 Calculated by the number of times the current drawing is processed.

 The corresponding meanings of the parameters in this module are as shown in the table below:

Figure 4-35 Production plan

The parameters are shown below:

Table 4-16 Production Plan Parameters

Parameters Description
Part production plan The system counts the number of processed parts and allows manual reset. It will

automatically stop and print completion information upon reaching the specified

quantity. A setting of zero disables this function. The counting function is enabled

in proofing mode but disabled during simulation or dry run

Total production

plan

The system calculates based on the number of file processing cycles. The count

increments by one each time a file is completely processed. Manual reset is

supported.

Drawing production

plan

The system tracks processing cycles for the current drawing. The count increments

automatically upon successful completion of each file processing task. A manual

reset function is available for the counter.

Manage/Password The function can be password-protected to prevent unauthorized modification of

production statistics.
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When importing special drawings (nesting job packages containing multiple processable nesting files

in the production plan), a new module will appear on the existing interface as shown below:

Figure 4-36 Cycle Production Settings

Once Nest task package production mode is checked, Auto switch to next nesting after preset

cuttings finished will be automatically checked. You can choose whether to check Prompt user when the

last nesting finished.

4.9 Center/Position

Center is used to measure the deviation between the tube center and the rotation center (the center of

B-axis), so that the processing accuracy can be ensured. Thus, the Center shall be executed before

processing, and the software will record the deviation. There are various types of centering in TubePro,

applicable for different tubes.

Table 4-17 Center Parameters

Centering Type Tubes General Tube Section

4-Point Center
Rectangular tubes, round

tubes, oval tubes.

5-Point Center
Rectangular tubes, oval

tubes.

Elliptical Tube

Center
Elliptical Tube.

L Section Center
Angle steel with an included

angle of 60° ~ 150°.

I-Beam Center For I-Beams.

Square tube find Suitable for tubes with two
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Centering Type Tubes General Tube Section
edge and center adjacent right-angle edges,

such as rectangular pipes,

square tubes, L/C-shaped

steel (angle steel, channel

steel, C-shaped steel), and

special-shaped tubes (select a

suitable centering method

according to the actual tube

section).

Symmetric Arc

Center

Suitable for tubes with

symmetric arcs.

Single Face Level

Pipes with straight edges in

the cross-section can all be

used, such as I-beams and

D-shaped steel.

Manual Center Special-shaped tubes that cannot automatically center.

Advanced Manual

Center

For center script centering, the centering action can be independently programmed

or used with external sensors such as probes and other equipment.

After importing a file, the system will automatically identify the tube type and match a suitable

automatic center-finding method. If multiple automatic center-finding methods are applicable to this tube

type, you can select the automatic centering method in Debugging Quick Settings (i.e., the settings

button below Auto Center); if there is no matching automatic centering method for this tube type, please

select manual centering or advanced manual centering as appropriate.

Notice: Before center-finding for all tubes, ensure that the tube clamping angle is basically

consistent with the drawing. If the angle deviation is large, first perform Single-Face Level or Set

Current Horizontal State to align the tube clamping angle with the drawing.
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4.9.1 Tube Profile Measurement

Open via Tools→Center/Position→Tube Profile Measurement for manual operation.

Figure 4-37 Manual Tube Profile Measurement

In addition to standard cross-section scanning, this function includes measurement and correction of

tube R-corner radii. Parameter explanations are shown below

 Automatic R-Corner Recognition: For square/rectangular tubes or C-channels, the system
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automatically detects R-corners during profile measurement (automatic detection disabled for R ≤ 5

mm).

 R corner result: For square tubes/rectangular tubes/C-section steel, the system automatically detects

the size of the radius corner, supports manual modification, and applies it to the current tube, and

updates the radius corner size after manual or automatic tube contour measurement is completed.

 Restore R corner: One-click restoration to the radius corner size in the original drawing.

 Scan result: After completing tube contour measurement, the scanning result will be displayed in the

tube contour scanning window together with the original trajectory (original trajectory in green,

actual trajectory in cyan).

Figure 4-38 Tube profile measurement

Figure 4-39 Rectangular tube profile
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Unlike the activation method of centering (deviation compensation is applied to the cutting process

as soon as centering is completed), the deviation compensation for tube contour measurement must be

enabled in conjunction with processing parameters. Click Techniques→Others, and check Tube Profile

Offset (V/Y Bevel).

Figure 4-40 Tube Profile Measurement

4.9.2 Single Face Level

Click Tools→Center/Position→Single Face Level, and you will see the window below.

Figure 4-41 Single Face Level
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Single Face Level can correct a flat surface of the tube to a horizontal state and align this surface

with the default upward-facing side in the drawing. After clamping the tube, single-surface leveling can

match the actual clamping position with the drawing.

If a drawing is imported, the software automatically retrieves the dimensional width; if no drawing is

available, manually enter the width of the surface to be leveled. Then move the nozzle directly above the

tube, click Single Face Level, and click Save after the operation is complete to finish leveling.

Example: For a triangular tube as shown, the drawing defaults the longest side to face upward, but if

the tube is initially clamped with the longest side positioned downward at an angle, it does not match the

drawing and cannot be processed. In this case, jog the longest side to a roughly horizontal position, then

perform single-surface leveling to fully align the clamping state with the drawing.

Figure 4-42 Triangular tube leveling

When using Single Face Level, ensure all axes have returned to their mechanical origins after

power-up, the tube dimensions are correctly entered, and the cutting head nozzle is directly above the

tube (use Return Center to quickly adjust the nozzle position). After leveling, click Save.
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4.9.3 4-Point Center

Click Tools→Center/Position→Height Controller Center→4-Point Center, and you will see the

window below.

Figure 4-43 4-Point Center

4-Point Center is applicable to rectangular tubes, round tubes, and waist-shaped tubes. During

centering, the system follows the four surfaces of the tube to find their coordinates, automatically

calculates the deviation between the tube center and the mechanical center, and compensates for it during

cutting.

Before starting, confirm the tube dimensions, ensure all axes have returned origin after power-up,

and verify centering and leveling. Click Start; and the X and Z deviation values will display in the

interface after completion.

4.9.4 5-Point Center

Applicable to rectangular tubes and waist-shaped tubes. Unlike Four-Point Center, this function
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automatically levels the tube, so no separate single-surface leveling is required.

Click Tools→Center/Position→Height Controller Center→4-Point Center, and you will see the

window below.

Figure 4-44 5-Point Level and Center

4.9.5 Multi-Face Center

Click Tools→Center/Position→Height Controller Center→Multi-Face Center, and you will see

the window below.

Figure 4-45 Multi-Face Center
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Multi-Face Center is applicable to triangular tubes, polygonal-section tubes, and non-standard tubes

with at least two non-parallel edges. The center of the non-standard tube is defined as the center of its

outer bounding box.

Click Start, and all edges in the cross-section with a length greater than or equal to the Minimum

Detection Width will be followed. After the following is completed, the system will return to the first

cross-section and automatically calculate the deviation between the tube center and the mechanical center,

displaying the deviation value in Centering status and results. If there is interference with the cutting

head during cross-section following, check Follower centering at dock height.

4.9.6 Ellipse Center

Click Tools→Center/Position→Height Controller Center→Ellipse Center, and you will see the

window below.

Figure 4-46 Ellipse Center

Ellipse Center can be used to find the deviation between the elliptical tube center and the

mechanical center. Before use, jog the elliptical tube to a state where the major axis is roughly horizontal,

then perform Single Face Level. Ensure all axes have returned origin after power-up, tube dimensions are

correctly entered, and the nozzle is directly above the tube.
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4.9.7 L Section Center

Click Tools→Center/Position→Height Controller Center→L Section Center, and you will see the

window below.

Figure 4-47 L Section Center

Applicable to angle irons with an included angle of 60° to 150°. Unlike other centering methods, the

result includes L-Beam Angle Deviation A, which provides the deviation (in radians, where 1° = 0.01745

rad) of the angle between the two surfaces from the standard 90°.

4.9.8 Find Edge and Center

Find Edge and Center is applicable to tubes with two adjacent right-angled edges, such as

rectangular tubes, square tubes, L/C steel (angle steel, channel steel, C-shaped steel), and special-shaped

tubes (select a suitable center-finding method according to the actual tube shape).
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Click Tools→Center/Position→Height Controller Center→Find Edge and Center, and you will

see the window below.

Figure 4-48 Find Edge and Center

4.9.9 Symmetric Arc Center

Click Tools→Center/Position→Height Controller Center→Symmetric Arc Center, and you will

see the window below.

Figure 4-49 Symmetric Arc Center
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Symmetrical Arc Center is suitable for special-shaped tubes with fully curved surfaces (no flat

surfaces) and symmetrical about the YOZ plane. During center finding, the widest surface must face

upward. You can manually jog to roughly level the wide surface, check Level before centering, and the

system will automatically level once before center finding to ensure the wide surface is horizontal. If

fixed fixtures are used during clamping, causing the wide surface to maintain a specific angle with the

horizontal plane each time, you can input the Clockwise Rotation Angle to rotate the pipe to a roughly

horizontal position of the wide surface before leveling (if checked).

4.9.10 I-Beam Center

Click Tools→Center/Position→Height Controller Center→I-Beam Center, and you will see the

window below. This center-finding method applies to I-beams. Before center finding, confirm that the

system has returned to the center and been leveled.

Figure 4-50 I-Beam Center
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4.9.11 Advanced Manual Center

Click Tools→Center/Position→Height Controller Center→Advanced Manual Center, and you

will see the window below.

Figure 4-51 Advanced Manual Center

Advanced Manual Center is suitable for special-shaped tubes that cannot be automatically centered.

Take the special-shaped tube shown in the diagram below as an example: the software will find the

highest points on the upper, lower, left, and right surfaces, and select one of them as the reference point.

Figure 4-52 Special-shaped tube

For example, if the right point is selected as the reference point, rotate the tube until the right side is

horizontally upward. Jog the cutting head to directly above the right point, click Start Center, and after
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center finding is complete, click Save to exit the interface.

4.9.12 Calibrate B-axis and Square Tube Centering

When the mechanical structure is fixed, the B-axis has a fixed rotation center. Calibrating the B-axis

is to determine the coordinates (X, Z) of this rotation center on the XZ plane. To measure the B-axis

center, a standard rectangular tube without chamfers is required. Before calibration:

 Ensure the system's X, Z, A, and B axes have returned to their origin positions.

 Move the cutting head directly above the rectangular tube.

 Enter the width and height of the rectangular tube, click Start Centering to calibrate.

After calibration, the coordinates of the B-axis center and the deviation from the tube center will be

displayed in Centering status and results.

Figure 4-53 Calibrate B-axis and Square Tube Centering

4.9.13 Manual Center

Some special-shaped tubes cannot be automatically centered and require manual leveling, as well as

inputting deviations in the X and Z directions.

Thus, it is essential to level one side of the tube to ensure it is clamped consistent with the drawing.
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If single-side leveling is impossible, jog the tube to roughly match the drawing, then click Manual

Center→Set Current Horizontal State.

Move the cutting head to the midpoint of the tube in the X direction, record the current X mechanical

coordinate, and calculate the center offset in the X direction by referencing the B-axis center calibration

results. Center offset X = Tube Center Coordinate X - Mechanical Center Coordinate X.

Figure 4-54 Manually set the tube center offset

4.9.14 Center During Processing

For longer tubes, issues like twisting, eccentricity, and deformation may occur due to gravity and

other factors. As the tube center may shift after each processing segment, the accuracy is affected. To

address this, center-finding points can be set on the processing graph. When machining reaches such a

graph, an automatic center-finding operation will be performed first before continuing with the

processing.
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For a single selected graph: Click Find Center in the left toolbar to set the starting point of the graph

as the center point. For multiple selected graphs: Click Find Center, and after setting the minimum

interval between center-finding points within the part, the system will automatically place center-finding

points. Additionally, you can choose to perform center finding at the start of each part.

Figure 4-55 Setting center points

The automatic center-finding mode during processing can be selected on the Settings page.

Figure 4-56 Center settings
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4.9.15 Single Face Center

 Based on single-face center finding, expand center-finding modes in file parameters to select

single-face center finding for surfaces A, B, C, or D.

 Default single-face center-finding modes (7 types): Single Face Center, Left Find Edge, Right Find

Edge, Level + Single Face Center, Level + Left Find Edge, Level + Right Find Edge, and Script

Center.

Figure 4-57 Centering modes

 Script Center supports custom center-finding actions or external sensors like probes.

 Special-shaped tubes default to surface A center finding.

 For tubes with stable errors in left/right edge finding, use deviation correction scripts for

compensation.

张静华



张静华
图上有一个script center

张静华
格式，缺少图注



TubePro User Manual for Two-Chuck Machines

www.bochu.com.en 59

4.10 Cutting Head

4.10.1 BLT Cutting Head Debugging

If you have configure BLT cutting head, also enabled Spot control in Machine Config tool, and

checked BLT, then you can see the BLT Laser Head Diagnosis page on TubePro. Click Tools→Laser

Head → BLT Head Debug, and you can see the window below.

Figure 4-58 BLT Cutting head debugging
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The meanings of parameters in function testing are as follows:

Table 4-18 Focus Motor Test

Parameter Description
Origin Signal During origin returning, when the cutting head baffle passes the induction position, the

limit switch is triggered, and the origin signal light turns on.

Ready Signal After power-on, when the motor has no servo alarm and phase searching is successful,

the ready signal light turns on.

Current

overload

When the motor is blocked or stuck, and the motor current exceeds the set value, this

signal becomes active.

Current Z

phase shift

Displays the Z-phase deviation of the current homing operation after origin is completed.

Initial Z

phase offset

Displays the Z-phase deviation after completing the installation origin.

Location Positions the coordinate of the focus motor.

Table 4-19 Sensors

Parameter Description
Protective

Window

Temperature

Monitors the temperature rise of the protective window to determine its cleanliness,

effectively avoiding cutting instability caused by window contamination.

Alarms are issued when the sensor fails, temperature is high, or temperature rise is

high.Protective

Chamber

Temperature

Cutting Gas

Pressure

Displays the gas pressure and temperature inside the current cutting head, and issues

a warning when the sensor fails or the monitoring function is not enabled. Cutting

pressure monitoring thresholds can be configured in Machine Config tool.Cutting Gas

Temperature

Capacitance Displays the capacitance value between the current cutting head and the tube. An

alarm will be triggered when the capacitance becomes 0 or the cutting head touches

the tube.

Sensor Head

Temperature

Displays the current sensor head temperature and turns off the laser in advance when

the sensor head is disconnected. An alarm will be triggered when the capacitance

sensor head temperature is too high or disconnected.

Focusing Lens

Temperature

It can monitor the contamination of the focusing lens.

When the sensor fails, the temperature is high, or the temperature rise is high, a

warning will be issued.

When the temperature is excessively high or the temperature rise is excessive, an
Core Chamber

Temperature
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Parameter Description
alarm will be triggered.

Protective

Window

Cartridge Gas

Pressure

Displays the current gas pressure in the protective window cartridge and issues an

alarm when the cartridge leaks air.

Upper Protective

Window Stray

light

Contaminants on the mirror cause diffuse reflection of the laser, known as stray light.

The contamination level of the upper protective window can be judged by the

displayed value to prevent window explosion, and an alarm prompt of Lower

Protective Window Contamination will be issued when exceeding the configured

alarm threshold.

Lower Protective

Window Stray

Light

Contaminants on the window cause diffuse reflection of the laser beam, resulting in

stray light.

The contamination level of the lower protective window can be determined by the

displayed stray light value. This helps prevent window explosion and triggers an

alarm prompt for Lower Protective Window Contamination when exceeding the

configured threshold.

Focusing Lens

Stray Light

Contaminants on the lens cause diffuse reflection of the laser beam, resulting in stray

light. The contamination level of the focusing lens can be determined by the

displayed stray light value.
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Gas Correction adjusts the relationship between the DA proportional valve voltage and gas pressure

to ensure precise pressure output during processing. Click Quick Gas Correction.

Figure 4-59 Gas Correction

On the page of Gas Correction, you can monitor the target gas pressure and current gas pressure

values for the selected gas type to determine the current gas status, such as whether there is a gas

shortage.

Figure 4-60 Gas Pressure Test
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4.10.2 Auto Focus Test

Click Tools→Laser Head→Auto Focus Test, and you will see the window below.

Figure 4-61 Auto Focus Test

The automatic focus test is used to find the actual focus value corresponding to the zero focus of the

cutting head. The usage steps are as follows:

Step 1 Select the spot to be tested, modify the focus range and focus spacing, set the processing line

parameters, and click Generate File to generate a test drawing based on the parameters.

Step 2 Click Layer above the layer color block on the right side of the software page, and set the Beam

Diameter to the spot value to be tested.

Figure 4-62 Beam diameter
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Step 3 Execute the processing operation to cut the test pattern.

Step 4 Analyze the cutting effects at different focus points, find the one with the thinnest cutting kerf

width, enter the corresponding focus value into Focus calibration, and click Write Calibration to

perform focus compensation.

4.11 Debug Tools

4.11.1 Auto Gas Correction

Please refer to Gas Correction.

4.11.2 Common Axis Debug

You can select the specified axis for jogging, returning origin in this window.

Figure 4-63 Common axis debugging

4.11.3 Tape Shot

Click Tools→Debug Tools→Tape Shot, and you will see the window below.

Figure 4-64 Tape Shot
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Tape Shot is used to check for window contamination in the optical path. The usage method is as

follows:

Step 1 Place tape at an appropriate position below the cutting head.

Step 2 Adjust the laser parameters.

Step 3 Click Burst.

Step 4 After emitting Burst, inspect the light spot on the tape to determine whether the lens is

contaminated. If contamination is present, further detection is required to identify the source of

contamination.

4.11.4 Z-Phase Signal Initialization

Click Tools→Debugging Tools→Z-Phase Signal Initialization to open the page as shown below.

Figure 4-65 Z-Phase Initialization

Perform Z-phase signal initialization when the machine is first manufactured, after mechanical

adjustments, or after resetting the origin switch.
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Notice: To use this function, check Use Z-Phase Signal in Return Origin parameters of Axis

Configuration in Machine Configuration tool .

Figure 4-66 Using Z-Phase Signal

4.12 Installation Tool

4.12.1 Cycle Production Test

Click Tools→Installation Tools→Cycle Production Test to display the interface as shown below.

This function is used to set parameters for cycle production test. You can fill in the planned cycles,

finished cycles, and cycle interval, and clear the displayed number of cycles after starting the test, and

select the PLC process and cycle count.

Figure 4-67 Cycle Production Test settings
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4.12.2 Optics Adjustment Interface

Click Tools→Installation Tool→Optics Adjustment Interface, you can see the window below.

Figure 4-68 Interferometer program

This function adjusts the optical path of the coordinate axis. Click to generate the program in the

blank area below the pop-up window. After confirming the program is correct and the following

conditions are met, click Start to begin measurement:

 Condition 1: The measured axis has correctly returned to the origin, and measurement starts from the

origin.

 Condition 2: The interferometer is ready, and its parameters match those set in the software.

Table 4-20 Interferometer Parameter Table

Parameter Requirements
Dwell time Set slightly longer than the interferometer’s Minimum Stop Cycle to ensure correct point

recognition.

Range Automatically read; must match the value set in the interferometer. Enter negative values

for origin in the forward direction, and positive values otherwise. The system will prompt

for errors during saving.

Cycles Must match the Measurement Count set in the interferometer. Since the software only

reads results from one round trip, multiple measurement data will only import the first set

of results.

Interval Must match the value set in the interferometer; otherwise, data may not be measured.

Gap When moving in the reverse direction, the system will first continue moving the set

distance in the original direction, then return the same distance to eliminate mechanical

backlash. This value should not exceed the interval value minus the tolerance; otherwise,

the interferometer may misidentify it as a measurement point.
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4.13 Advanced Tools

4.13.1 New Motor Tuning Tool

Click Tools → Advanced Tools → New Motor Tuning Tool, and you will see the window below.

Figure 4-69 New Motor Tuning Tool

The parameters are shown below:

Table 4-21 New Motor Tuning Tool

Parameter Name Requirements
Single Axis Debug Mainly used to check if the inertia ratio of the single-axis servo is correct and if the

static torque is normal.

Multiple Axes

Synchronization

Used for roundness testing, rectangularity testing, circular tube cladding roundness

testing, oblique cutting, and custom trajectory testing. Tests the error between

graphic commands and feedback positions.
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In Test Path, fill in parameters, and click Generate Path to create a test pattern. Click Start Testing;

the blue trajectory displayed on the interface is the feedback actual trajectory, and corresponding error

values will show in Test Results.

Figure 4-70 View errors

4.13.2 Find Edge Repetition Accuracy

Click Tool→Advanced Tools→Find Edge Repetition Accuracy to display the interface as shown

below.

Figure 4-71 Find Edge Repetition Accuracy
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This function tests the edge-finding performance of the height controller to check if it meets

specifications. Normal 2D nozzle edge-finding maximum error: within 0.08 mm. Normal 3D nozzle

edge-finding maximum error: within 0.12 mm.

4.13.3 Square Tube Profile Accuracy

Click Tool→Advanced Tools→Square Tube Section Accuracy to display the interface as shown

below. Section analysis visualizes the appearance of rectangular tubes and tests deviations between the

current tube and an ideal rectangular tube.

Figure 4-72 Square tube section accuracy

4.13.4 Coordinates Viewer

Click Tools→Advanced Tools→Coordinates Viewer to view the machine coordinates of the current

position or manually switch the main axis controlled by the jog operation panel.

Figure 4-73 Coordinates Viewer
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4.13.5 Create CAD Test File

Click Tools→Advanced Tools→Generate CAD Test File to open the page as shown below.

To facilitate trial cutting, TubePro provides a function to create test files, allowing quick creation of

through-hole graphic on rectangular tubes for simple testing.

Figure 4-74 Create CAD test file

Select rectangular or circular holes and set the distance from the hole center to the near end face. Set

tube surface *.DXF cladding, import the corresponding *.DXF file, and enter the cladding start position

and left/right section distances.

4.13.6 Advanced Debug Tools

Click Tools→Advanced Tools→Advanced Debugging Tool and select Set Current as Mechanical

Origin to set the current position of the cutting head as the origin (resetting X/Y/A/B coordinates to 0).

Please use with caution.
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4.14 Global Parameters

Global parameters include settings for production, motion parameters, algorithm parameters, and

regular units.

Figure 4-75 Global Parameter Settings

4.14.1 Production Settings

The parameters are shown below:

Table 4-22 Production Setting Parameters

Parameter Description
Task End, Y-axis

return
Options: Zero Point/End Point.

Task End, B-axis

return

For special machine types, the B-axis rotates at the end of processing to facilitate

loading.

Quick Frog Leap

distance

When checked, traveling smaller than this value performs fast Frog leap (no

lift/delay), while larger movements use leap with lift/delay; unchecked disables leap.

Lift height when

rotation exceeds

10°

Z-axis lift height for surface switching without traveling optimization (disabled when

air movement optimization is enabled).

Max follow

height
Sets a maximum following height for capacitive sensing limitations of sharp nozzles.

Height controller Time required for the height adjuster to complete following actions.
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Parameter Description
follow in-place

delay

GasOn delay
This is to make sure that the gas pressure at the cutting head stabilizes after the gas

circuit opens.

GasSwitch Delay

When changing the gas, there should be a delay from completely purging the original

gas to the new gas reaching a stable pressure at the cutting head. First gas blow after

processing starts adds an extra gas change delay to the gas on delay as the initial gas

on delay.

Cooling point

Delay
The time for blowing gas to cool down at the cooling point.

GasOff Delay

After completion of the cutting process, it is advisable to introduce a delay before

shutting off the gas. By implementing this delay, the number of gas opening actions

for short-distance cuts can be minimized.

Stepback when

resume
Retraction distance of the cutting head when resuming after a pause.

Frog leap lift Uses leap lift during travel.

Travel path

optimization
Optimizes Z-axis lift based on tube dimensions in the graph during travel.

Enable auto

loading
Executes the Loading PLC before the File Start PLC when processing begins.

Enable auto

unloading
Executes Unloading PLC after the End File PLC at processing completion.

Enable following

holder before

production

If equipped with a following holders to auto-engage the holder coupled following

mode before processing.

Check chuck

clamping before

production

Checks chuck status before starting; prompts an alert if not clamped.

Couple following

holder after

Return Zero

Engages holder in coupled following mode after each homing.

Speed parameters

for weight

calculation

Sets different Y/B-axis travel speeds, accelerations, and cutting accelerations based

on tube weight (up to 6 groups).

Auto center

rectangular tube

Enables real-time deviation calculation for rectangular tubes (only available for bus

systems), collecting Z-value data during cutting to update the configuration file.
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Parameter Description
at cutoff line

Auto center

before production
Forces centering for the first cut of parts (ineffective for non-standard tubes).

Early GasOn
(Checked by default) Enables pre-gas activation during travel to improve efficiency

and reduce gas on delay per trajectory.

Early switch

technique

(Checked by default) Parallelizes process setting time, focus, spot size, laser power,

etc., during travel to improve efficiency.

4.14.2 Motion Parameters

Figure 4-76 Motion parameters
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The parameters are shown below:

Table 4-23 Motion Parameters

Parameters Description
Travel Speed for

X/Y/A/B axes
Set the max travel speed for X/Y/A/B axes.

Max travel acceleration Set the max travel speed for X/Y/A/B axes.

Travel low pass filter
Sets the low-pass filter frequency for travel (default: 5 Hz). Adjust it to a

smaller value to reduce cutting deviation.

Max Cutting Speed Constrains single-axis processing speed for X/Y/A/B axes.

Cutting acceleration Constrains single-axis processing acceleration for X/Y/A/B axes.

CAD sample precision
Improves precision and smoothness of processed curves by setting sampling

accuracy.

Small circle sample

optimization

Sets independent CAD precision for small circles;

Ineffective for TubesT clad circles and punching circles;

Applies to *.igs or .*sat parts

Trajectories are valid for circular holes, not valid for ellipses, rectangular

tubes, or non-closed shapes;

Cutoff lines, replacement with lines, and replacement with points are not

valid.

Fly Cut Parameters Sets overshoot distance for fly cuts to ensure complete hole cutting.

System latency
Automatically calculates and compensates for system delay via EtherCAT bus

to ensure multi-axis synchronization and hole position accuracy.

Range of Feedrate
Controls cutting speed by adjusting the effective range of feed rate overrides

for process debugging.
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4.14.3 Algorithm Parameters

Figure 4-77 Algorithm Parameters

The details are shown below:

Table 4-24 Algorithm Parameters

Parameter Name & Description

Algorithm

Parameters

Efficiency-Precision Weight: Cutting low-pass filter frequency (default: 5 Hz). Higher

machine performance allows higher acceleration and filter frequency.

Small Circle Time Constant: Minimum time parameter for small circle processing

(larger values improve precision).

Z-Axis

Algorithm
Three Z-axis control algorithms for different scenarios.

张静华
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4.14.4 Regular

Figure 4-78 Speed unit

The parameters are shown below.

Table 4-25 Regular Parameters

Parameter Name & Description
System unit The system supports two unit types: Metric and Imperial.

Speed unit

 Millimeters per second (mm/s), Meters per second (m/s), Meters per minute

(m/min); Millimeters per minute (mm/min);

 Inches per minute (in/min); Inches per second (in/s).

Rotary axis

coordinate unit

Radians.

Degrees/RPM (degrees per minute) Revolutions + Degrees

Length unit Millimeters (mm); Inches (inch).

Acceleration unit

 Metric:

 Millimeters per second squared (mm/s²)

 G (1 G = 10 meters per second squared, m/s²)

 Meters per minute squared (m/min²)

 Meters per second squared (m/s²)

 Imperial:

 Inches per second squared (in/s²)

 Feet per second squared (ft/s²)

Gas pressure unit Bar, Psi (pounds per square inch), MPa (megapascals)
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4.15 Technique Parameter Setting

If there are multiple layers of a drawing, then each layer can be configured with specified techniques.

You can configure them according to actual needs.

4.15.1 Cutting Techniques

You can set parameters including Cut speed, Gas pressure, Power, Delay in Techniques.

Figure 4-79 Cutting techniques
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The parameters are shown below:

Table 4-26 Cut Technique Parameters

Parameter Description

Lift height
The height by which the Z-axis is lifted when traveling from the end of one

cutting path to the start of the next during normal machining operations.

Beam/Focus
If a cutting head with electric focus adjustment is used, parameters for the

beam/focus can be configured.

Dwell time
The delay from the start of cutting to the movement along the trajectory is set

to ensure that the laser can burn through the tube material.

Laser off delay The time from the end of the trajectory to the laser shutdown.

Slow Lead
Used to set the distance, speed, laser frequency, and duty cycle for the starting

part of each trajectory.

Slow Stop
Used to set the distance, speed, laser frequency, and duty cycle for the ending

segment of each trajectory.

Low Pass Filter
If enabled, a separate low-pass filter for this layer can be set; if not enabled,

this layer will use the low-pass filter for processing in the global parameters.

Realtime power

regulation

Set the relationship between the laser power/frequency and the cutting speed

for trajectory processing.

Modify curve Specifically edit the curve that maps power/frequency to cutting speed.

Defilm

The laser power can be reduced beforehand to remove the oxide layer or

protective coating on the tube surface. After checking this option, parameters

for the surface cleaning process need to be configured.

Keep Gas on
When checked, the gas supply remains continuously on from the start to the

end of processing.
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4.15.2 Pierce Techniques

Click Layer, and you will enter the window to set the technique parameters.

Figure 4-80 Layer Technique Parameters

Select the layer, and click Pierce, and then you can configure the pierce method, and pierce

parameter.

You can select piercing method, including No Pierce, 1-stage, 2-stage, and 3-stage, and adjust the

parameters. There are three types of piercing, including Segment Pierce, Flash Pierce, Incremental Pierce.

If the piercing method is set to both 2-stage piercing and 1-stage piercing, 2-stage piercing will be

performed first, followed by 1-stage piercing. The related parameters are shown below:

Table 4-27 Piercing Parameter Table

Parameter Description
Segmented Pierce Uses corresponding parameters (power, frequency, duty cycle, etc.) at different

piercing heights to perform piercing within the set time.

Flash Pierce Rapidly changes frequency and power for piercing, enabling fast penetration of

thick tubes.

Incremental Pierce After piercing at the current height for the dwell time, the cutting head moves to the

next height at a certain speed (speed = height difference / piercing time) while

continuously emitting laser light.

Incremental time The time for the cutting head to move from the current height to the next height.

Nozzle height The height of the nozzle during piercing.

Gas type Sets the gas type used during piercing.
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Parameter Description
Gas pressure Sets the gas pressure during piercing.

Peak power Sets the laser peak power during piercing.

Duty cycle Sets the laser duty cycle during piercing.

Pulse frequency Sets the laser frequency during piercing.

Beam diameter If a focusing axis is configured, sets the piercing spot diameter.

Spot position If a focusing axis is configured, sets the piercing focus position.

Dewell time The time the cutting head stays at the current height for piercing.

LaserOff Blow The time for gas blowing after piercing stops.

4.15.3 Corner Technique

Enabling the corner processing technology can improve the cutting quality of pipe corners. On

Corner technique page, you can configure the following parameters: Follow height offset, corner pressure,

peak power, duty cycle, and pulse frequency. Additionally, you can constrain the speed and acceleration

of the B-axis.

Figure 4-81 Corner Technique
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The parameters of corner techniques are shown below.

Table 4-28 Corner Technique Parameters

Parameter Description
Follow height

offset

For the rectangular tube offset value, during a 90° rotation, the value first rises from

zero, reaches its maximum at 45° (which equals the process setting value), and finally

decreases back to zero.

Triangular tubes follow a similar pattern but with a 120° rotation angle, where the

maximum value is reached at the 60° mark during rotation.

Other tube types do not undergo height offset.

Corner

pressure

The gas pressure generated by the nozzle when cutting tube corners has a default value

of 5 bar.

Peak power If the machine’ laser uses DA (Digital-to-Analog) control for peak power, the peak

power during corner cutting can be configured separately.

Duty cycle When cutting corners, the duty cycle can be appropriately reduced to avoid burning the

workpiece.

Pulse

frequency

The pulse frequency during corner cutting is 5000 Hz by default.

Define corner When machining 1 mm in the X direction, if the B - axis needs to rotate a set angle, it is

considered that the corner section has been entered. It is recommended to use the

default value 1.146°/mm.

Limit B-axis

speed

The speed of B-axis has influence on the cutting quality of different tube types. Using

specified B-axis speed can improve the cutting quality without affect the entire cutting

efficiency.
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4.15.4 Part Features

Part Features are the parameters for different tubes or files.

Figure 4-82 Part Feature

The parameters are shown below

Table 4-29 Part Feature Parameters

Parameter Name Description

Section Type
The system will automatically recognize the section type and dimension based on

the file

Center type

Based on different tube types, the system will select the proper centering type.

When processing the graphic with centering point, the system will center first

before cutting.
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4.16 Custom Processes

Click PLC, and you can edit PLCs in the pop-up window.

Figure 4-83 PLC configurations

4.16.1 Overview of Custom Processes

Figure 4-84 Overview of PLC Custom Processes

For more instructions on PLC, please refer to TubePro PLC Instruction.

https://drive.weixin.qq.com/s?k=AJEAqwcIAAcKrT6wo5
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4.16.2 Script Function

Enter the Machine Config tool, open the Advanced Configuration interface, check Enable script

function, and save the settings.

In TubePro, click CNC Script Editor from the PLC Process drop-down menu to start writing scripts.

Figure 4-85 Script

During execution, scripts can trigger different action sequences based on external command (cmd)

values. Configure theWait for Script Execution Time:

If the timeout is exceeded, the software will issue an alarm prompt.

If set to 0, the software will wait indefinitely for the script to complete.

If unset, the script will run in parallel (non-blocking mode). Scripts can only be stopped via external

calls. Pressing the Stop button will not halt execution.
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Chapter 5 2-Chuck Functions

5.1 Dodge

Dodge is divided into Laser Head dodge and Chuck dodge. Select the Dodge type according to

your actual mechanical structure. The actions are as follows:

1. During cutting: The Y1 stroke of the main chuck gradually moves toward the dodge position. When

the next cutting trajectory exceeds this position, the dodge action is triggered.

2. Dodge sequence: Execute pre-dodge PLC commands. Move the dodge axis (direction depends on the

selected dodge type).

3. Execute post-dodge PLC commands. The position of the cutting head/chuck changes.

4. If Enable Y1 Axis Positive Stroke Dodge is configured, the positive stroke of the Y1 axis will also

be updated accordingly.

5.1.1 Dodge Trigger Conditions

The Dodge action triggers if the next cutting trajectory would cause the Y1 axis to move beyond the

specified position. For trajectories on the last part, Dodge can only trigger before the last part if Single

Part Detection is enabled.

Required conditions:

 Condition 1: Part extension length > dodge relative distance - Distance from middle chuck to cutting

head. If not met, dodge is blocked with an alert: Tube will be pulled out of the middle chuck.

 Condition 2: Enable dodge for short parts. If the part extension length < dodge relative distance -

Distance from middle chuck to cutting head, dodge triggers with automatic release of the middle

chuck.
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5.1.2 Cutting Head Dodge Parameter Configuration

Figure 5-1 Cutting head dodges

 Trigger: Y1 limit coordinate: The Y1 coordinate that triggers dodge if exceeded by the next

trajectory.

 Dodge axis: Choose a general-purpose axis and set its parameters.

 Speed: Movement speed during dodge.

 Dodge relative distance: Distance to move relative to the current position.

Notice: Positive/negative values matter. Default direction for cutting head dodge is negative

Y-axis.

 Dodge Axis Absolute Position: Check to move to an absolute coordinate (recommended).

 Distance from Y1 dodge Position to Cutting Head: Distance when dodge triggers.

 Distance from Middle Chuck to Cutting Head: Measured from the outer edge of the chuck jaws.

 Allow dodge for Short Parts: Bypasses checks for tube pullout, allowing single-chuck cutting.

 Pre-dodge Actions: Custom PLC commands (e.g., Z-axis lift, X-axis reposition, lowering support
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brackets).

 Post-dodge Actions: Custom PLC commands after dodge. Synchronize Y1 Axis with dodge Axis:

Check to move Y1 and the dodge axis together.

 Y2 Cutting Preparation Speed after Avoidance: Speed for Y2 to move to the cutting position (7-axis

systems only).

 Limit B-Axis Speed after Avoidance: Applies speed limits to the B-axis post-avoidance.

 Enable Y1 Positive Stroke after Avoidance: Adjusts the Y1 stroke range. Resets after processing.

5.1.3 Chuck Dodge Parameter Configuration

Figure 5-2 Chuck dodging configuration

 Trigger Condition & Y1 Limit Coordinate: Identical to cutting head dodge.

 Dodge Axis : Choose a general-purpose axis.

 Speed: Movement speed during dodge.

 Dodge relative distance: Distance to move relative to current position.

Notice: Default direction for chuck dodge is positive Y-axis.

 Dodge Axis Absolute Position: Check to move to an absolute coordinate (recommended).
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 Distance from Y1 dodge Position to Cutting Head: Distance when dodge triggers.

 Distance from Middle Chuck to Cutting Head: Measured from the outer edge of the chuck jaws.

 Allow dodge for Short Parts: Bypasses checks for tube pullout.

 Pre-dodge Actions: Custom PLC commands (e.g., Z-axis lift, bracket adjustments).

 Post-dodge Actions: Custom PLC commands after dodge.

 Synchronize Y1 Axis with dodge Axis: Move Y1 and the dodge axis together.

 Y2 Clamping Position after dodge: Position for Y2 to clamp (7-axis systems only).

 Limit B-Axis Speed after dodge: Apply speed limits post-dodge.

 Enable Y1 Positive Stroke after dodge: Adjusts Y1 stroke range. Resets after processing.

5.2 Bevel Cutting

Enable Bevel Cutting in Advanced Tools of the Machine Config tool. Configure the A-axis in the

Axis Configuration page. Refer to TubePro Bevel Precision Marking & Bevel Compensation for details.

https://drive.weixin.qq.com/s?k=AJEAqwcIAAcwi7RMyo
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5.3 Automatic Feeding

5.3.1 Enable 2-Chuck Automatic Feeding

Check Enable Db chuck AutoFeed in Chuck→Chuck Function (top menu of the Machine Config

tool). If a tailstock length sensor is installed, check Monitor tailing length input in the Tailing length

input port monitoring section.

Figure 5-3 Chuck Configuration
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5.3.2 Automatic Feeding Configuration

Click Auto Feed in the TubePro top menu and select Enable. Enter the tube length and feeding

range based on your material.

Figure 5-4 Auto-feed

 General settings

 Tube Length: Length of the current tube.

 Feed Range: Reciprocal stroke of the middle chuck (maximum: Y-axis total stroke).

Figure 5-5 Feeding Stroke
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Figure 5-6 The feeding stroke cannot exceed A1

Notice: For full-stroke 2-chuck machines, the feeding range cannot exceed Main Chuck dodge

Trigger Position A1 in the dual-chuck parameters.

 Automatic Feeding Judgment:

 Check Before Cutting Trajectory: Feed if the next trajectory exceeds the feeding stroke.

Minimizes feeding during a trajectory but may increase total feeds (ideal for long parts).

 Check Before Cutting Part: Feed if the next part exceeds the feeding stroke. Ensures no

feeding during a single part (ideal for short parts).

 Pre-Feeding PLC: Select PLC commands to execute before feeding.

 Post-Feeding PLC: Select PLC commands to execute after feeding.

Notice: Pre/post-feeding PLC commands must coordinate with auxiliary chuck

clamping/unclamping (do not manually configure output ports).

 Distance from Tube Tip to Cutting Head after Loading (Distance A): Measured after loading.

The Y-axis moves forward by Distance A before starting processing.

Figure 5-7 Distance A
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Figure 5-8 Distance A

Notice: Set Distance A to 0 if using Quick Align Tube Head after loading.

 Cutting Stroke

 Enable Cutting Stroke: Restricts all trajectories to a specified range for improved precision on

short features.

Notice: Cutting stroke must be shorter than the feeding stroke.

 Tail Detection

 Enable Input Monitoring: Use sensors to detect remaining tube length and prevent empty cut.

 Tailstock Error Compensation: Adjusts for sensor delay. The system calculates compensation

dynamically based on feeding speed.

 Special Functions:

 Automatic Feeding Mechanical Compensation: Corrects fixed errors from mechanical backlash.

 Enable Custom Feeding Speed/Acceleration: Set Y-axis rapid traverse speed during feeding.
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